Opened 10 years ago

Closed 9 years ago

#566 closed help (fixed)

script modifications

Reported by: iwi Owned by: ros
Component: UM Model Keywords:
Cc: Platform:
UM Version: 7.5

Description

Hi,

Please could you confirm that for making changes to scripts, I do it in exactly the same way as for source code changes?

In version 4.5 I'm used to a clear separation between fortran mods and script mods (even though the nupdate syntax for both is then the same), but in the repository I can see a "script" subdirectory of fcm:um/trunk/src, which suggests to me that I branch at the top level (above src) in both cases, and then put the update into the UMUI in exactly the same place regardless of whether it then contains script changes or fortran changes or a combination of the two. But please can you confirm this?

I see that there is a "UM Scripts Build" option under "Compilation and Modifications", so presumably I just turn this on?

Many thanks,
Alan

Change History (5)

comment:1 Changed 10 years ago by ros

Hi Alan,

Yes script modifications are made in the same way as source code changes. Also, in FCM, UM source and script modifications can co-exist in the same branch. There is no need to keep them separate. All branches are taken from fcm:um/trunk/src.

To include a branch it needs to be listed in the Include modifications from branches table in the UMUI window:
FCM Configuration —> FCM options for atmos and recon

If you want to test out your changes before committing them to the repository then enter the path to your working copy in the Include modifications from user working copy box at the bottom of the above window.

You only need to turn on the "UM Scripts Build" option if you want to re-extract the UM scripts and not recompile your model executable. If you are compiling the model executable the UM scripts will be extracted automatically too.

Regards
Ros.

comment:2 Changed 10 years ago by iwi

Ros,

Thanks.

Alan

comment:3 Changed 10 years ago by iwi

Ros,

I am trying to modify scripts in a run-only NEMO-only job, but the "UM Scripts Build" option doesn't seem to do anything - the leave file shows that the full path to the scripts that are being run is just the standard one owned by the "hum" user rather than any private build.

Indeed, I have tried seeing what difference this switch actually makes to the processed job (by processing the same job twice with and without the option and doing a recursive diff between copies of the resulting ~/umui_jobs/$RUNID directory), and I find the only difference that it makes (apart from the human-readable JOBSHEET file) is in the basis_$RUNID.gz file itself, which although copied to HECToR when you submit is I assume not used for anything on HECToR. Also when I click submit, there seems to be no attempt to do the extraction on puma regardless of whether the "UM Scripts Build" option is enabled - this is based on the UMUI submit results popup and looking under ~/um/um_extracts on puma.

I then tried turning compilation back on, and it seems to do the script build okay on puma (although I haven't yet tested if it then uses the modifed scripts to run with, as I need to sort out a quota exceeded problem first).

Please can you tell me if I'm doing something wrong or if this is something that needs to be fixed.

Thanks,
Alan

comment:4 Changed 10 years ago by ros

  • Owner changed from um_support to ros
  • Status changed from new to accepted

Hi Alan,

It's a bug in the UMUI! The flag for the UM Scripts Build is output within an atmos loop. I've applied a fix to UMUI vn7.5. You'll need to close and reopen the UMUI job to pick up the changes, before trying again. Your modified scripts will be picked up as the PATH setting looks in the experiment/bin directory before the central scripts directory.

...:/work/n02/n02/iwi/um/xerag/bin:/work/n02/n02/hum/vn7.5/pathscale_quad/scripts...

Ros.

comment:5 Changed 9 years ago by ros

  • Resolution set to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.