Opened 9 years ago

Closed 9 years ago

#574 closed help (fixed)

Run failure on job xfsya

Reported by: raw88 Owned by: willie
Component: UM Model Keywords:
Cc: Platform:
UM Version: 7.3

Description

Hi,

I’m having trouble running a Global model job on HECToR. The job (xfsya) was copied from a job I previously ran (xfpia) which worked fine. The only differences between the jobs is the start dumps and the STASH diagnostics. The original job was part of the PS22 example suite from the user umui on PUMA, so the start dump and STASH were not set by me, whereas I did set them in the new job. I verified my diagnostics and did a CHECK SETUP before running and these showed no errors. The job compiles fine with the .comp.leave file showing no obvious errors. However, the .leave file has numerous messages saying the following:

**** Segmentation fault!  Fault address: 0x669438


Fault address is 560072 bytes below the nearest valid mapping boundary, which is at 0x6f2000. 

This is likely to have been caused by a stack overflow.

Use your shell's ulimit or limit command to see if your stack size limit is too small.

…along with the following error message:

ERROR!!! in reconfiguration in routine Rcf_Exppx

Error Code:-  2

Error Message:-  Cant find required STASH item  490  section  0  model  1  in STASHmaster

Error generated from processor  0


I am not sure what the reason for this error is – I haven’t requested the diagnostic 0490, though I notice that it is present in the start dump…could that be it? And are the former messages about a “Segmentation fault” related to the error or are they something different?

My .leave files for the job are all in /home/n02/n02/raw88/um/umui_out/xfsy on HECToR and my username on PUMA is raw88 if it helps.

Thanks for your help,

Rob Warren

Change History (5)

comment:1 Changed 9 years ago by willie

  • Owner changed from um_support to willie
  • Status changed from new to assigned

Hi Rob,

The STASH item 490 does not appear until vn7.5 (Your start dump was created by vn7.5). We need a way of reconfiguring this data at vn7.3. I'll let you know when I've found it.

Regards,

Willie

comment:2 Changed 9 years ago by willie

Hi Rob,

I have a new user STASH file in my home directory on PUMA: STASH_7.3_7.5. In The UMUI, under STASH > user STASH master, add this to the table at the top. This will get past the reconfiguration problem.

Regards,

Willie

comment:3 Changed 9 years ago by raw88

Hi again,

I tried repeating my run with the additional STASH file however it once again failed during the reconfiguration run, this time returning the message:

ERROR!!! in reconfiguration in routine Setup_LSM_Out
Error Code:- 50
Error Message:- Number of land points does not agree with input namelist!
Error generated from processor 0

in my .leave file. In the output this problem is detailed as followed:

Reconfiguration Error
No of land points in output land_sea mask = 104488
No of land points specified in namelist RECON = 104538
Please reprocess the job with the correct number of land points in the UMUI panal
*
ERROR!!! in reconfiguration in routine Setup_LSM_Out
Error Code:- 50
Error Message:- Number of land points does not agree with input namelist!
Error generated from processor 0
*

There was no land-sea mask file defined in the original job so I do not have one in mine. Do I need one now with the updated STASH file? Or is there something else?

Regards,

Rob

comment:4 Changed 9 years ago by willie

Hi Rob,

This is one of those annoying things. You just have to run the job again with the correct number of land points from the .leave file.

regards

Willie

comment:5 Changed 9 years ago by willie

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.