Opened 9 years ago

Closed 7 years ago

#581 closed help (fixed)

Strange behaviour when archiving to MONSooN /nerc disk

Reported by: luke Owned by: jeff
Component: MONSooN Keywords: archiving
Cc: Platform: <select platform>
UM Version: 7.3

Description

Hello,

I am running a N96L85 UM7.3 HadGEM3-A r2.0 + UKCA job, which is using my branch

fcm:um_br/dev/luke/VN7.3_HadGEM3-A_r2.0_Archiving_CCL0

which is based on Jeff's branch

fcm:um_br/dev/jeff/VN7.3_HadGEM3-A_r2.0_hector_monsoon_archiving

The strange behaviour is that this job only seems to archive the seasonal and annual means, plus the monthly mean produced when the seasonal mean is produced. The other monthly mean files are left in the job run directory. Also, the dump files are not archived, but left in the job directory.

This happens with my job xfpbp, and a copy of this job xfpbr (which is currently running). Both these jobs were initialised from dumps from previous jobs (xfpbi, and xfpbp respectively). I've never seen this happen before, and I am unsure how to fix this. Job xfpbi, from which xfpbp was copied (with some changes), does not show this behaviour but was started as an NRUN using a .astart file, rather than a dump in the other cases.

Any advice would be much appreciated.

Many thanks,
Luke

Change History (5)

comment:1 Changed 9 years ago by jeff

  • Owner changed from um_support to jeff
  • Status changed from new to accepted

Hi Luke

Did you copy the non .pp monthly mean files into the archive directory by hand?

I'm not sure what is going wrong, I would need to put some debug code in the qsserver script. If you want to try and debug this then change these lines in qsserver

  read PERCENT CURRENT_RQST_NAME CURRENT_RQST_ACTION CURRENT_RQST_TYPE \
  DATA_TYPE
  RC=$?

# Copy the input request to a file in case data remains on cray disk

  if (( $RC == 0 ))
  then
    echo "$PERCENT $CURRENT_RQST_NAME $CURRENT_RQST_ACTION \
    $CURRENT_RQST_TYPE" >> $DATAM/$RUNID.requests
  fi

to this

  read PERCENT CURRENT_RQST_NAME CURRENT_RQST_ACTION CURRENT_RQST_TYPE \
  DATA_TYPE
  RC=$?
  echo "qsserver: PERCENT = $PERCENT RC = $RC"

# Copy the input request to a file in case data remains on cray disk

#  if (( $RC == 0 ))
#  then
    echo "$PERCENT $CURRENT_RQST_NAME $CURRENT_RQST_ACTION \
    $CURRENT_RQST_TYPE" >> $DATAM/$RUNID.requests
#  fi

I added the RC variable if code so the archiving would work on Hector, it's not needed on Monsoon.

Jeff.

comment:2 Changed 9 years ago by luke

Hi Jeff,

I've changed those lines in qsserver, so hopefully that will give some information.

For job xfpbp I did manually copy some of the .pm files across (those are the ones which have not been converted to .pp). However, I haven't done that with xfpbr (yet). I'll have a play around with some more things and see if I can fix it.

Thanks for your help,
Luke

comment:3 Changed 9 years ago by luke

Hi Jeff,

I think the issue is to do with a new hand-edit that we have to include due to new functionality in the code. Jobs that do not include this hand-edit archive normally, jobs that do include it do not. I'll look into exactly what it's doing in more detail.

thanks,
Luke

comment:4 Changed 9 years ago by luke

Changing the order of the hand-edits seems to have had an effect for some of the jobs, but not all. Without the hand-edit works fine, but the source code is different too, and it is impossible to use the new source-code without the hand-edit, or the hand-edit without the new source-code. I'll keep looking.

Thanks,
Luke

comment:5 Changed 7 years ago by jeff

  • Platform set to <select platform>
  • Resolution set to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.