Opened 9 years ago

Closed 9 years ago

#598 closed enhancement (fixed)

New soil albedos in CAP

Reported by: cbirch Owned by: um_support
Component: UM Tools Keywords: CAP soil ancillary
Cc: Platform:
UM Version: 7.1

Description

Hi,

I am looking to run a high resolution LAM over the Sahara. I need a good representation of (soil) surface albedo for this. At the moment the soil data available from the the NCAS Central Ancillary Program is out of date. In November 2008 CLASSIC albedos became operational at the Met Office.

Houldcroft, C. J., W. M. Grey, M. Barnsley, C. M. Taylor, S. O. Los, and P. R. J. North (2009), New vegetation albedo parameters and global fields of soil background albedo derived from MODIS for use in a climate model, J. Hydrometeor., 10, 183–198.

I have talked to Malcolm Brooks at the Met Office and he says that their version of CAP includes this new data. I was wondering if it would be possible to include this data set on the NCAS version because the currently available data set is prettycrude?

Thanks,
Cathryn

Change History (6)

comment:1 Changed 9 years ago by grenville

Cathryn

The MODIS CLASSIC soil albedo data is available through a pre-release CAP at
http://ncas-cms.nerc.ac.uk/~grenville/CAP_INTERFACE/cap_general.php. Select the option on the Vegsoil page.

Grenville

comment:2 Changed 9 years ago by cbirch

Hi Grenville,

Thanks for that. I've created some ancillary files the the albedos look great.

Cathryn

comment:3 Changed 9 years ago by cbirch

Hi Grenville,

I created the new soil ancillary files without any problems and the soil albedo data looks fine. When I configure it in a 12km res LAM over Africa the .astart file looks fine and the model runs to completion and creates all the output files. The problem is that all the output diagnositic files contain nan's at all times, except at the boundaries (this data will have come from the LBC's).

I'm not sure why this would happen. If it was, for example,the high resolution of the new soil albedo causing lots of mesoscale circulations over the desert surely the model would produce good data for at least few hours into the run. On the other hand the data in the ancillary and astart files seems fine so I am not sure what the issue is.

I have tried using a land-sea mask created from the new CAP version because from the new soil albedo data I could see that it doesn't have data over a few rivers and lakes that weren't resolved in the old data. I also tried reducing the time step from 5 to 2.5 mins but neither of these things helped.

The job is xfxux.

Cheers,
Cathryn

comment:4 Changed 9 years ago by grenville

Cathryn

I checked with Stuart Webster at the MO who forwarded my query to Malcolm Brookes whose reply I attach. However, it appears that none of the potential pitfalls mentioned will cause the model to fail so early. I notice in xfxux that you have reconfigured a new mask - was that exactly the same mask as used to get all the other ancillary files? Some of the ancillaries use the mask to mask out the land during their creation, so if the lsm seen by the model isn't exactly the same as that used to create all the ancillaries there will be problems.

FYI

The data should also be used in conjunction with an amended set of
albedos for the vegetated tiles (set in BL, land surface) to
Broadleaf trees: 0.143
Needleaf trees: 0.088
C3 grass: 0.192
C4 grass: 0.159
Shrubs: 0.115
That's a science issue, not a immediate failure issue though. The values
are from Houldcroft et al 2008 (Journal Hydrometeorology), with the
crops setting used for C3 grass (because we don't have a crop tile).

To get the seasonal change in albedo it should also be used in
conjunction with the monthly varying climatology of LAI. Again, that's a
science issue, not something to make the model instantly fail.

If the file is an proper ancil file, and it reconfigures in OK, then the
issue could be related to the soil moisture. The file with the soil
albedo also contains ancils for the soil hydrology. If these are
inconsistent with the soil moisture then failures can occur. More recent
versions of the UM have a recon QC panel, and interpolating soil
moisture stress, rather than soil moisture, can fix this (I think).

Is the soil moisture climatology being reconfigured? If so, then that
soil moisture clim must be consistent with the soil properties file.

Thanks,

Malcolm

Grenville

comment:5 Changed 9 years ago by cbirch

Hi Grenville,

Thanks for the info from Malcolm - that is useful to know.

I tried the job again with a newly-produced set of ancillary files and made sure that I was using ALL the new ancillaries and it works fine now.

You can close this ticket if you like.

Thanks for your help,
Cathryn

comment:6 Changed 9 years ago by grenville

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.