Opened 9 years ago

Closed 9 years ago

#600 closed error (fixed)

LAM jobs now do not compile on phase2a and 2b

Reported by: cbirch Owned by: um_support
Component: UM Model Keywords:
Cc: Platform:
UM Version: 7.1

Description (last modified by ros)

Hi,

Whilst testing my UM 12km LAM jobs on phase 2b I got this error when compiling:

     &, lat        &pathf95 INTERNAL: Message system failed trying to issue message 1259
  Possible reasons include:
   * The message catalog has been corrupted.
   * The message catalog is out of date or does not match the compiler release.
fcm_internal compile failed (512)
gmake: *** [idl_pr_balance.o] Error 1
gmake: *** Waiting for unfinished jobs....
gmake -f /home/n02/n02/cbirch/xfylw/ummodel/Makefile -j 8 all
failed (2) at /work/n02/n02/hum/fcm/bin/../lib/Fcm/Build.pm line 597

(This is xfylw000.xfylw.d11094.t143217.comp.leave).

I went back and tested a similar job on phase 2a and got a similar error (xfxuz000.xfxuz.d11094.t154136.comp.leave), so I don't think it is to do with compiling on phase2b.

I have recomplied this job many times in the past and it has now stopped working. Do you know what this error means?

Cheers,
Cathryn

Change History (4)

comment:1 Changed 9 years ago by ros

  • Description modified (diff)

Hi Cathryn,

The problem is caused by the setting of the variable NLSPATH in Defined Environment Variables for Directories table in UMUI window Input/Output? Control and ResourcesTime Convention and SCRIPT environment variables.

If you remove NLSPATH from this table your job will compile successfully on both the XT4 and XE6.

The reason this problem has only surfaced now is due to a UMUI fix I copied out last Friday to fix the problem you have been having with the compiles not copying your exec and scripts into the $DATAW/bin directory. [The environment variables in the above table, which includes the variable $DATA_OUT which you use to then define the path for $DATAW, weren't being exported in the compile script so the bin directory couldn't be created.]

If you ever need to have the NLSPATH variable set it should be placed in the Defined Environment Variables table in the window Script Inserts and Modifications

Regards,
Ros

comment:2 Changed 9 years ago by ros

Hi Cathryn,

I also forgot to say that I noticed a hand-edit that you are using in your job that isn't needed as it is specific to UM7.0 and has the potential to cause problems.

The offending hand-edit is:

/home/ros/umui_jobs/fcm_handedits/vn7.0_fixes.ed

Regards,
Ros.

comment:3 Changed 9 years ago by cbirch

Hi Ros,

I did as you suggested above and the jobs compile and run fine now.

Thanks a lot for your help with this. You can close this now if you like.

Cheers,
Cathryn

comment:4 Changed 9 years ago by ros

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.