Opened 9 years ago

Closed 9 years ago

#602 closed error (fixed)

Error in vertical levels specification for LBC output

Reported by: a.elvidge Owned by: um_support
Component: UM Model Keywords:
Cc: Platform:
UM Version: 7.6

Description

 *********************************************************************************
 UM ERROR (Model aborting) :
 Routine generating error: IntfCtl
 Error code:  20
 Error message:
Vertical Levels Namelist file does not exist!
 *********************************************************************************
%PE21 OUTPUT%

 LBC Area  1  : $UMDIR/vn7.6/ctldata/vert/vertlevs_UK4_L70

  LBC Vertical Levels file: $UMDIR/vn7.6/ctldata/vert/vertlevs_UK4_L70

xfxka, running on MONSooN. The file $UMDIR/vn7.6/ctldata/vert/vertlevs_UK4_L70 does exist, so I dont understand what the problem is.

Any ideas?

Cheers, Andy

Change History (3)

comment:1 Changed 9 years ago by lois

Try using the full path rather than $UMDIR and see if the vertical levels file can be found.

Lois

comment:2 Changed 9 years ago by a.elvidge

Thanks Lois, that has worked. Do you know why it doesnt understand $UMDIR? I copied the job from someone who must have run it before, using $UMDIR.

Thanks, Andy

comment:3 Changed 9 years ago by lois

  • Resolution set to fixed
  • Status changed from new to closed

Reading environment variables like $UMDIR doesn't always work from Fortran so it may depend on where the job had been run and with what compiler.

Lois

Note: See TracTickets for help on using tickets.