Opened 9 years ago

Closed 9 years ago

#603 closed error (fixed)

Error in ancil versions file

Reported by: a.elvidge Owned by: lois
Component: UM Model Keywords:
Cc: Platform:
UM Version: 7.6

Description

Job xfxkb, running on hector.
I am getting an error - comes right at the top of my .leave file, afterwhich there is no more content.

/var/spool/PBS/mom_priv/jobs/980300.sdb.SC[137]: .[9]: .: /work/n02/n02/aelvidge/ancil/ancil_versions/filenames/v1: cannot open [No such file or directory]

I cant work out why it is looking for /n02/aelvidge/ancil/ancil_versions/filenames/v1 however, since I have specified in the 'Ancilliary version files' box the following location:

/work/n02/n02/aelvidge/OFCAP/ancil_versions/filenames/v1

Thanks, Andy

Change History (5)

comment:1 Changed 9 years ago by lois

  • Owner changed from um_support to lois
  • Status changed from new to assigned

Hello Andy,

I cannot see the files in /work/n02/n02/aelvidge/OFCAP/ as I don't have permission so could you check that all the files exist.

If I look in /home/n02/n02/aelvidge/umui_runs/xfxkb-098151847
there are already warnings about the versions file.

if test -f /work/n02/n02/aelvidge/OFCAP/ancil_versions/filenames/v1
SCRIPT:. /work/n02/n02/aelvidge/OFCAP/ancil_versions/filenames/v1
SCRIPT: echo "ERROR: the Ancil filenames version /work/n02/n02/aelvidge/OFCAP/ancil_versions/filenames/v1 not found"

Lois

comment:2 Changed 9 years ago by a.elvidge

Lois,

You should have access to everything now.

I am sure they exist.

Please note though that, strangely, the error message says "/work/n02/n02/aelvidge/ancil/ancil_versions/filenames/v1: cannot open [No such file or directory]", and doesnt even refer to /work/n02/n02/aelvidge/OFCAP/ancil_versions/filenames/v1

Cheers, Andy

comment:3 Changed 9 years ago by lois

Hello Andy

In your file
/work/n02/n02/aelvidge/OFCAP/ancil_versions/ANT4/v1

you have specified
UM_ANCIL_FILENAMES=${UM_ANCIL_FILENAMES:-$DATADIR/ancil/ancil_versions/filenames/v1}

so I suspect this is the cause of your error message. Try making this consistent with what you have specified in the UMUI and I hope that your job will get further.

Lois

comment:4 Changed 9 years ago by a.elvidge

Thanks Lois, that worked.

Andy

comment:5 Changed 9 years ago by lois

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.