Opened 9 years ago

Closed 8 years ago

#619 closed help (fixed)

Failed compilation of mod in different version of UM

Reported by: mx020105 Owned by: lois
Component: UM Model Keywords:
Cc: Platform:
UM Version: 4.5

Description

Dear helpdesk,

I have written a mod (attached) and tested it in the UM 4.5. The mod compiles and runs successfully. The Met Office are now trying to implement the same mod in their UM version 4.5 [CPP], which is UM version 4.5c.

The mod fails at compilation stage saying that the all of the relevant lines in the mod cannot be found in the code (see attached compilation output). The fact that all of the lines cannot be found makes me worry that there is a fundamental problem with implementing the mod in this different version of the code.

It would be helpful if I could gain access to the program library for the version 4.5c to check whether any of the decks have been renamed or whether any of the standard UM 4.5c mods overwrite the lines I reference in my new mod.

Do you have any ideas about what might be the problem?

Many thanks,
Amanda Maycock

Attachments (2)

ajzvxnew2.txt (20.5 KB) - added by mx020105 9 years ago.
depresys_control.mf77 (2.6 KB) - added by mx020105 9 years ago.

Download all attachments as: .zip

Change History (10)

Changed 9 years ago by mx020105

Changed 9 years ago by mx020105

comment:1 Changed 9 years ago by lois

  • Owner changed from um_support to lois
  • Status changed from new to assigned

Hello Amanada

On HECToR (and MONSooN) we have both UM vn 4.5 and vn 4.7 installed while, as far as I am aware, the Met Office only have vn4.7 installed. So you could try testing your mod in vn 4.7 on HECToR but we don't all the mods that are listed in the Met Office .leave file so you may still have some overlap between the depresys mods and yours.

Lois

comment:2 Changed 9 years ago by mx020105

Hi Lois,

Thanks for your reply.

I had a look for a UM 4.7 job on puma that I could copy to test my mod in on HECToR. I saw that you have two vn 4.7 jobs, xfpnh and xfdga. Would you be able to advise me if these are suitable vn 4.7 jobs to copy as a test bed? Also, since I haven't used vn 4.7 before, what would I need to change in my .profile file to set up the correct set-up?

Thanks a lot,
Amanda

comment:3 Changed 9 years ago by lois

Hello Amanda,

I would suggest using xfpnh but I am sorry I can't rember if this ever ran! If you look at the README file in
/work/n02/n02/hum/vn4.7
this tells you what to set for the setvars and what extra mods you need to run on HECToR.

It was Simon Wilson who set up UM vn4.7 on HECToR and he is in Singapore on Met Office work for the next week or so. In the mean time I will try and help you get your job up and running.

Lois

comment:4 Changed 9 years ago by mx020105

Hi Lois,

I have tried to compile your xfpnh job and another one I found from Simon as a starting point, but I get the following error message which I have encountered before:

PBS Job Id: 990855.sdb
Job Name: xfuvu000
Post job file processing error; job 990855.sdb on host nid00011

Unable to copy file /var/spool/PBS/spool/990855.sdb.OU to nid15875:/xfuvu000.xfuvu.d11131.t164607.comp.leave

error from copy

nid15875: Connection refused

end error output

Output retained on that host in: /var/spool/PBS/undelivered/990855.sdb.OU

The only things I have changed in the job so far are my user details and target machine. Do you know off hand what I might be doing wrong?

Thanks,
Amanda

comment:5 Changed 9 years ago by lois

I can't instantly see what is wrong Amanda, I will have an expore and get back to you.

Lois

comment:6 Changed 9 years ago by mx020105

Hi Lois,

There has just been some progress with my colleague at the Met Office in getting the mod to compile on their machines, so it's no longer urgent for me to get this test to run.

Incidentally, the way the Met Office got rid of most of the compilation errors was to simply retype the mod! I'm not sure quite what difference that has made, but it seems to have overcome most of the compilation errors related to not finding the relevant lines of code.

Thanks,
Amanda

comment:7 Changed 9 years ago by lois

Sometimes carriage returns get screwed up so this could the cause of the problems.
Lois

comment:8 Changed 8 years ago by ros

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.