Opened 9 years ago

Closed 8 years ago

#623 closed error (fixed)

Error with processing jobsheet at UM vn7.7

Reported by: frec Owned by: ros
Component: UMUI Keywords:
Cc: Platform:
UM Version: 7.7

Description

When I process any UM vn7.7 job with the "Copy jobsheet to the job library" option enabled I get an error message pop up saying;

"ERROR: bad index "%1": must be integer or end?-integer?"

This does not occur when I run with that option disabled, previous versions of the UM on PUMA, or if I run exactly the same job on the MO UMUI.

It does not seem to affect the running of the job but it's rather annoying and I'm curious to understand what it means?

Thanks,
Emilie

Change History (4)

comment:1 Changed 9 years ago by ros

  • Owner changed from um_support to ros
  • Status changed from new to accepted

Hi Emilie,

Thanks for reporting this error. I am aware of this problem, but have not yet determined the cause. I only know of one other person who has encountered this behaviour. As you say it only occurs when the jobsheet option is enabled and doesn't affect the submission or running of the job.

Could you let me know the job id of the job that is displaying this problem, as the few 7.7 jobs that I have do not exhibit this behaviour when the jobsheet option enabled, which makes it a little more challenging to track down.

Regards,
Ros.

comment:2 Changed 9 years ago by frec

Hi Ros,

Thanks, the job id's of my 7.7 jobs are xfyg[c,d,e,f,j,k,l,m] and xfzya. I think the other person who reported the problem copied my xfzya job.

Emilie

comment:3 Changed 8 years ago by ros

  • Component changed from UM Model to UMUI

Hi Emilie,

I've tracked the problem down to an extraneous % sign in the use of an array in the User STASH Diagnostics window. You should now be able to process the jobsheet successfully.

Regards,
Ros.

(See also #615)

comment:4 Changed 8 years ago by ros

  • Resolution set to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.