Opened 9 years ago

Closed 9 years ago

#629 closed help (fixed)

ancillary file for new ocean tracer

Reported by: nathaelle Owned by: jeff
Component: UM Model Keywords: ancillary, tracer
Cc: Platform:
UM Version: 4.5

Description

Hi,

I've added ocean tracers to FAMOUS. It runs ok when I initialise them to zeros. But I want to initialise some of them to other values. I've thus set the option to 7 for tracer 3 in the "initialisation of user prognostics" panel of the umui, and I've created an ancillary file with the values: /net/chestnut/export/chestnut/data-24/nathaelle/ANCILLARY/initT3. But I get a segmentation fault during the reconfiguration (in /home/nathaelle/umui_out/xgand000.xgand.d11147.t150259.leave):

/home/nathaelle/tmp/modscr_xgand/qsprelim: Executing dump reconfiguration program /net/chestnut/export/chestnut/data-24/nathaelle/xgand/xgand.recon

forrtl: severe (174): SIGSEGV, segmentation fault occurred
Image PC Routine Line Source
xgand.recon 0000000000544FFC Unknown Unknown Unknown
xgand.recon 0000000000458B7C Unknown Unknown Unknown
xgand.recon 0000000000425CDE Unknown Unknown Unknown
xgand.recon 000000000047C505 Unknown Unknown Unknown
xgand.recon 0000000000471DF0 Unknown Unknown Unknown
xgand.recon 000000000040033C Unknown Unknown Unknown
xgand.recon 0000000000543A00 Unknown Unknown Unknown
xgand.recon 0000000000400209 Unknown Unknown Unknown
/home/nathaelle/tmp/modscr_xgand/qsprelim: Error in dump reconfiguration - see OUTPUT

So I suppose that my file is not right but I can't find why, do you know what is wrong, or if I should do differently?

Thanks,

Nathaelle

Change History (4)

comment:1 Changed 9 years ago by jeff

  • Owner changed from um_support to jeff
  • Status changed from new to accepted

Hi Nathaelle

The important error message from your file is this

OPEN:  File $data/ANCILLARY/initT3 to be Opened on Unit 145 does not Exist
OPEN:  **WARNING: FILE NOT FOUND
OPEN:  Ignored Request to Open File $data/ANCILLARY/initT3 for Reading
 **FATAL ERROR WHEN READING/WRITING MODEL DUMP**

The problem is you can't use environment variables in the "initialisation of user prognostics" panel and need to enter the full pathname.

Another problem you might have is that umui panel only allows file names of up to 50 characters.

Jeff.

comment:2 Changed 9 years ago by nathaelle

Hi Jeff,

Thanks, I indeed first tried to put the full path but it exceeded the limit, so I then used the environment variables. I' ve now changed where the ancillary file is, and put the full path name, but I get negative pressure value (in /home/nathaelle/umui_out/xgand000.xgand.d11151.t154804.leave):

OPEN: File /net/chestnut/export/chestnut/data-24/nathaelle/ANCILLARY/xfrnr_qpsclim_prim_0 to be Opened on Unit 113 Exists

*
*
Model completed with the following :

Error Code : 1
Message : P_TH_ADJ : NEGATIVE PRESSURE VALUE CREATED.

*

What am I doing wrong?

Nathaelle

comment:3 Changed 9 years ago by jeff

Hi Nathaelle

This error usually means your model has gone unstable and crashed. I guess it doesn't like your new ancillary file.

Jeff.

comment:4 Changed 9 years ago by jeff

  • Resolution set to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.