Opened 9 years ago

Closed 9 years ago

#640 closed help (fixed)

HadGEM2-AMIP run with different land sea mask

Reported by: peterh Owned by: lois
Component: UM Model Keywords:
Cc: j.cole@… Platform:
UM Version: 6.6.3

Description

Hi
I am trying to reconfigure and run the AMIP HadGEM2 job with a new land sea mask (glacial maximum). It appears to perform the reconfiguration OK, but then fails in the first few timesteps, but I cannot see why, beyond the fact that all of the sea-ice fields appear to be corrupted. The job is xfxtq, any help would be most appreciated!

WARNING q_POS : UNABLE TO RESET VALUES CONSERVATIVELY
WARNING q_POS : 27458 points were less than 1.00000000000000002E-8 and have been reset to 1.0000

0000000000002E-8

WARNING q_POS : All other points unchanged
GATHER_FIELD: Non-Zero Error Code 2
GATHER_FIELD: Message: GATHER_FIELD: Error in COEX
STASH_GATHER_FIELD : Failed during GATHER_FIELD
Error code : 2
Message : GATHER_FIELD: Error in COEX
Error occured in STASH while gathering data for output.
STASH : Error processing diagnostic section 30 , item 417 , code 2

Failed to gather field

*
UM ERROR (Model aborting) :
Routine generating error: Atm_Step
Error code: 2
Error message:

Failed to gather field

thanks
Peter

Change History (9)

comment:1 Changed 9 years ago by lois

  • Owner changed from um_support to lois
  • Status changed from new to assigned

Hello Peter,

I think that you are the first person we need to ask to NOT use the revision number on the standard NCAS branch
fcm:um_br/pkg/Config/HG6.6.3_ncas/src
Jeff Cole found the long standing bug in the model which had been causing all sorts of problems with reconfiguration and we decided that the best way to sort this out was to add the fix to the NCAS branch. We are trying to use this standard branch for all our bug fixes and changes which should not change the science - aprat from allowing the science to happen of course. So the advice we are giving is do not use a revision number on this standard branch. I know Dan Lunt raised the issue yesterday that you may want to be doing validation and so you actually want to validate or compare with bugs and features included! But the number of people doing this is very small so the generic advice is not not include this revision number.

So if you remove the revision number (just for this branch) and remove old code on HECToR and PUMA - in other words have a clean slate for this job - then I hope that your problem with the reconfiguration will be solved. It has solved most of the reconfiguration problems we have seen like yours so please let us know if it hasn't and we will continue to look at these issues.

Lois

comment:2 Changed 9 years ago by peterh

Hello Lois,

I'm afraid removing the revision number from
fcm:um_br/pkg/Config/HG6.6.3_ncas/src
hasn't made any difference. I wasn't sure though whether I needed to tick 'Force FULL extract' and/or 'Force FULL build' though?

Any further suggestions would be great.
thanks
Peter

comment:3 Changed 9 years ago by lois

The model has well and truly blown up… perhaps your changes are too drcaonian for the model.
I will have to have a further look and see if I can make some suggestions.

Lois

comment:4 Changed 9 years ago by lois

Could I suggest you resolve the STASH issues Peter. If you do Cntl v in the STASH window you will get the list of all the problems. You must have turned off climate meaning, did you mean to?

Lois

comment:5 Changed 9 years ago by peterh

Hi I did turn the meaning off, but I've reset this as in the standard job to no avail.

I have now gotten this to run by making the fractional land sea mask the same as the normal land sea mask, i.e. only 1s or 0s, and no fractional values. This implies that the fractional land sea mask was causing the model to crash. Do you have any ideas why this might be?
thanks

comment:6 Changed 9 years ago by lois

  • Cc j.cole@… added

Hello Peter,

looking at the standard AMIP job (under the userid umui) it uses a land fraction file and this does not seem to cause any problems. So the question is how did you create all your new ancillary files? I presume that you are using XANCIL to create your ancillary files and Jeff Cole tells me that you should create your land fraction file first and then make sure that all the other ancillary files use this land fraction file. I can't see your land fraction file with fractional values on HECToR so you must have already replaced this file. It might be an idea to explain to Jeff (as he is the expert!) what you did to create your files and he might be able to spot something wrong.

Lois

comment:7 Changed 9 years ago by peterh

It seems that there were some values very slightly > 1 in the land fraction file, now that I've sorted this the model seems to run OK!

I'm just testing whether removing the revision number from the FCM is required or not.

comment:8 Changed 9 years ago by peterh

It looks as though removing the revision number isn't necessary, the run seems to be fine with the original executables.

Thanks for all of your help, the ticket can be closed now.

comment:9 Changed 9 years ago by ros

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.