Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#643 closed help (fixed)

Problems with ssh-add on PUMA

Reported by: luke Owned by: ros
Component: PUMA Keywords: ssh-add
Cc: emxin, oma Platform:
UM Version:

Description

Xin Yang at Cambridge has been having a problem with the UMUI asking for a passphrase for submission of jobs to HECToR. When running ssh-add he gets the error:

Could not open a connection to your authentication agent.

I also get this error running ssh-add. This seems to cause problems when submitting UM jobs.

Thanks,
Luke

Change History (5)

comment:1 Changed 9 years ago by ros

  • Owner changed from um_support to ros
  • Status changed from new to accepted

Hi Luke,

That's weird, someone else has had the same problem today. It's not a general problem though as my and others' logins are still working ok.

The error message implies that your ssh-agent has stopped running.

Can you look in your $HOME/.ssh directory on PUMA and if you have a file called environment.puma move it out of the way or delete it. Then log out and back into PUMA which should trigger a new ssh-agent to be initialised (you'll get a line saying "Initialising new SSH agent…"), assuming you have the standard ssh setup script called from your .profile.

You should then be able to run ssh-add successfully.

Cheers,
Ros.

comment:2 Changed 9 years ago by luke

Hi Ros,

That seems to work for me now! Thanks for your help. It does seem strange that it works OK for some people and not others.

Thanks,
Luke

comment:3 Changed 9 years ago by ros

  • Resolution set to fixed
  • Status changed from accepted to closed
  • UM Version <select version> deleted

Glad that worked. Yes it is rather odd that only some people are affected. Usually when this happens it's because a user has a slightly different setup or has setup an additional ssh to another machine or similar. Although sometimes, I'd swear ssh has a mind of its own!!

comment:4 Changed 9 years ago by oma

Hello,

Just to say I was having the same problem today. I followed your instructions above, Ros, but everytime I logged back into PUMA the environment.puma was created again. At the end I deleted it and without logging out I ran ssh-add. That seemed to fix the problem.

Regards,

Oscar

comment:5 Changed 9 years ago by ros

  • Cc oma added

Hi Oscar,

Thanks for letting me know you had the same problem. The reason for removing the environment.puma file was so that a new ssh-agent could be started and this file will be recreated as part of that process. This file holds some ssh-agent identification info and the setup script looks for it before deciding whether a new agent needs intialising or not.

You may find that since you removed the environment.puma file and then ran ssh-add that you will need to re-run ssh-add the next time you login to PUMA.

Cheers,
Ros.

Note: See TracTickets for help on using tickets.