Opened 9 years ago

Closed 9 years ago

#647 closed error (fixed)

Build-only job fails (FCM)

Reported by: a.elvidge Owned by: willie
Component: UM Model Keywords:
Cc: Platform:
UM Version: 7.6

Description

Hi,

Job xfxky is a vn7.6 build-only job for a 1.5km LAM running on hector. It fails with many error lines which look like this:

pathf95-5 pathf90-3.2.99: ERROR ATMOS_PHYSICS1, File = /home/n02/n02/aelvidge/compile/xfxky/ummodel/ppsrc/UM/control/top_level/atmos_physics1.f90, Line = 198
5, Column = 7
  The type-declaration statement is out of order.

and then:

pathf95: PathScale(TM) Fortran Version 3.2.99 (f14) Sun Jul 10, 2011  01:36:40
pathf95: 3785 source lines
pathf95: 87 Error(s), 0 Warning(s), 0 Other message(s), 0 ANSI(s)
pathf95: "explain pathf95-message number" gives more information about each message
fcm_internal compile failed (512)
ftn -o mcica_mod.o -I/home/n02/n02/aelvidge/compile/xfxky/ummodel/inc -I/home/n02/n02/aelvidge/compile/xfxky/umbase/inc -i8 -r8 -fno-second-underscore -O3 -I
 /work/n02/n02/hum/gcom/pathscale/gcom3.6/hector_pa_mpp/inc -c /home/n02/n02/aelvidge/compile/xfxky/ummodel/ppsrc/UM/atmosphere/radiation_control/mcica_mod.f
90
gmake: *** [atmos_physics1.o] Error 1
gmake: *** Waiting for unfinished jobs....
gmake -f /home/n02/n02/aelvidge/compile/xfxky/ummodel/Makefile -j 6 all failed (2) at /work/n02/n02/hum/fcm/bin/../lib/Fcm/Build.pm line 597
Build failed on Sun Jul 10 02:26:57 2011.

Im sure that fcm:um_br/dev/a.elvidge/VN7.6_theta_budgets/src is the offending branch (I have made some edits in this branch to atmos_physics1.f90. However, I am running this very same branch with no problems on job xfxkb.

Any ideas?

Thanks, Andy

Change History (4)

comment:1 Changed 9 years ago by willie

  • Owner changed from um_support to willie
  • Status changed from new to assigned

Hi Andy,

the problem is the statement

     write(6,*) 'elvidge1'

occurs in the middle of the type declarations. You need to put this after all of them.

Regards,

Willie

comment:2 Changed 9 years ago by a.elvidge

Hi Willie,

I edited out the 'elvidge1' write statement in a recent revision, so I was not expecting this to still be in the branch. Perhaps I am not understanding fcm correctly. I made the change and then typed 'fcm update'. This gave me the new revision number which I specified in the umui. Do I need to use 'fcm commit' every time I make a revision?

Thanks, Andy

comment:3 Changed 9 years ago by willie

Hi Andy,

If you are going to put print statements in, it might be better to check out a local working copy: there is box on the FCM configuration page for this. Remember to switch off the branch that your making a local copy of. You can then make changes to the local copy. If you don;t want to do this then you'll have to commit the changes.

Regards,

Willie

comment:4 Changed 9 years ago by willie

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.