Opened 9 years ago

Closed 8 years ago

#649 closed help (fixed)

Problem Running UM 7.4

Reported by: pclark Owned by: um_support
Component: UM Model Keywords:
Cc: Platform:
UM Version: 7.4

Description

I am re-running a job I've successfully run on Hector Phase2b before (some time ago). The job is xflvd and uses an exec /work/n02/n02/paclark/xflva/bin/xflva.exe, rebuilt yesterday with no obvious problems.

As soon as the run starts, it dies with lots of messages like

user-kernel cdev open failed: Permission denied

and

120: (portals/_pmi_portals.c:452) PtlNIInit failed : PTL_NOT_REGISTERED(36)
[PE_120]: PtlNIInit failed
[PE_120]: _pmii_portals_start failed
[PE_120]: _pmi_preinit: _pmii_inet_setup returned -1

Output is available at
/home/n02/n02/paclark/um/umui_out/xflvd000.xflvd.d11192.t145703.leave

I believe I've followed what there is on the NCAS site but I guess I'm missing something. Any help gratefully received.

Peter Clark

Change History (4)

comment:1 Changed 9 years ago by pclark

Note - I've read the Hector FAQ - this says
"This is a simple one. These error messages mean that you have not re-compiled your code for the Gemini interconnect on the XE6; you are using an XT executable. If you recompile the messages should disappear."

I thought I had re-compiled but I'll have another go!

comment:2 Changed 9 years ago by jeff

Hi Peter

In your job you have "Run from the standard executable" for the reconfiguration executable. This executable was built on the old hector so you will need to rebuild this as well.

Jeff.

comment:3 Changed 9 years ago by pclark

Actually, this job doesn't use reconfiguration, but I'm a bit confused by your comment. The 'standard executable' should be part of the UM library - I cannot rebuild it, only my own copies. Surely the UM library has been rebuilt?

Peter

comment:4 Changed 8 years ago by ros

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.