Opened 9 years ago

Closed 9 years ago

#655 closed help (fixed)

Timed out, puma.nerc.ac.uk not responding

Reported by: SimonDriscoll Owned by: ros
Component: PUMA Keywords: MONSooN
Cc: Platform:
UM Version: 6.6.3

Description

I have exactly the same problem as http://cms.ncas.ac.uk/trac/UMHelpdesk/ticket/651 and was advised to follow the steps given, namely:

1) Delete the file $HOME/.ssh/environment.puma on PUMA 2) Log out and log back in again. You should see a message saying "initialising new ssh-agent" 3) Run ssh-add which should then prompt for a passphrase.

After 1) I log out, and back in again. However, I see no message "initialising new ssh-agent". Instead I see two messages:

-bash: hello world: command not found
-bash: /home/SimonDriscoll/.ssh/setup: No such file or directory

Could I have advice on where to go from here?

Thanks,

Simon

Change History (5)

comment:1 Changed 9 years ago by ros

  • Keywords MONSooN added
  • Owner changed from um_support to ros
  • Status changed from new to accepted

Hi Simon,

Ok. That would imply that you don't have ssh setup in the standard way, as described for MONSooN here: http://cms.ncas.ac.uk/index.php/monsoon/1471-ssh-setup. Is that assumption correct?

Do you forward you ssh-agent from your local machine? What instructions did you use when you set it up initially? This will hopefully me figure out the setup you have and thus give the correct advice. Please try running the following command on PUMA.

puma$  ssh-add -l

If the response is:

Could not open a connection to your authentication agent

Then I don't think you are forwarding the agent.

Try running:

puma$ ssh-agent
puma$ ssh-add

ssh-add should then prompt you to enter your passphrase.

Hopefully you will then be able to submit your jobs again. If this works I then advise you to set up your session so that ssh-agent starts up automatically. I'll send you those instructions once I know what situation we are in.

Obviously let me know, along with any info from running the above commands, if you still have problems. ssh can be a pain when it goes wrong and it is sometimes easier and quicker to just set it up from scratch again.

Regards,
Ros.

comment:2 Changed 9 years ago by grenville

Simon

I can't see in your .ssh directory, but it's complaining that it can't find /home/SimonDriscoll/.ssh/setup - in my .ssh directory, the file is called ssh-setup (not just setup). Please check the file name.

Grenville

comment:3 Changed 9 years ago by SimonDriscoll

Dear both,

the response to ssh-add -l was 'The agent has no identities.'. However, I tried ssh-agent and ssh-add, and then tried ssh-add -l again, and got: '1024 bc:98:7a:5f:c1:bc:de:ef:28:0a:2b:d8:55:ff:de:da /home/SimonDriscoll/.ssh/id_dsa (DSA)' which looked like a sensible response from the website http://cms.ncas.ac.uk/index.php/monsoon/1471-ssh-setup ("If the result is similar to the above then you already have an ssh-agent running on PUMA."). I have tested whether I can submit jobs now, and I get no complaints on submission and on MONSooN I can see that my job has been submitted, so it seems to have fixed the problem.

Thanks,

Simon

comment:4 Changed 9 years ago by ros

Hi Simon,

Glad that worked. Now you should set your session up so that ssh-agent starts up automatically. As Grenville said, check whether you have a script called $HOME/.ssh/ssh-setup rather than $HOME/.ssh/setup and if so you will need to change the line in your $HOME/.profile to be

. $HOME/.ssh/ssh-setup

If you don't have this script then do the following:

Copy my setup script to $HOME/.ssh/setup, and ensure it has execute permission:

puma$ chmod u+x $HOME/.ssh/setup

Call this script from your .kshrc (if you don't have a .kshrc file call it from your .profile) by adding the following line:

. $HOME/.ssh/setup

Once you've done this ssh-agent should be started up automatically. Note: you may need to run 'ssh-add' every time a new ssh-agent is started - ie. every time you re-start your local session.

Ros.

comment:5 Changed 9 years ago by ros

  • Resolution set to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.