Opened 9 years ago

Closed 9 years ago

#656 closed error (fixed)

UMUI job won't open on PUMA

Reported by: nhsavage Owned by: um_support
Component: UMUI Keywords:
Cc: Platform:
UM Version: 7.3

Description

I seem unable to open my UMUI job xfyc#d as read write. I get a series of messages to the console as below and nothing happens.

nhsavage@puma:/home/nhsavage> Error in startup script: Server error couldn't open "/home/umui/umui/umui2.0/DBSE/xfyc/d.job": permission denied
    while executing
"error "Server error $error""
    (procedure "RPC" line 18)
    invoked from within
"RPC sock4 load_job xfyc d nhsavage 0"
    ("eval" body line 1)
    invoked from within
"eval "RPC $mserver $command $vals""
    (procedure "RunOnServer" line 9)
    invoked from within
"RunOnServer 1 $command $vals"
    (procedure "OnBothServers" line 11)
    invoked from within
"OnBothServers load_job [list $exp_id $job_id $env(LOGNAME)  [expr ! $read_write]"
    (procedure "get_basis_file" line 21)
    invoked from within
"get_basis_file $exp_id $job_id $job_file $read_write"
    invoked from within
"set writable [get_basis_file $exp_id $job_id $job_file $read_write]"
    (file "/home/umui/umui/ghui2.0/vn1.4/tcl/edit_job.tcl" line 48)

If after this I try again to open the job I am informed that it is opened read only as I already have it opened. If I do I force close on the job I get a pop up window with the following error (including the stack trace)

Server error couldn't open "/home/umui/umui/umui2.0/DBSE/xfyc/d.job": permission denied
STACK-TRACE:
Server error couldn't open "/home/umui/umui/umui2.0/DBSE/xfyc/d.job": permission denied
    while executing
"error "Server error $error""
    (procedure "RPC" line 18)
    invoked from within
"RPC sock5 force_close_job xfyc d"
    ("eval" body line 1)
    invoked from within
"eval "RPC $mserver $command $vals""
    (procedure "RunOnServer" line 9)
    invoked from within
"RunOnServer 1 $command $vals"
    (procedure "OnBothServers" line 11)
    invoked from within
"OnBothServers force_close_job [list $exp_id $job_id]"
    (procedure "menu_job_close" line 23)
    invoked from within
"menu_job_close"
    invoked from within
".mbar.2.3.menu invoke active"
    ("uplevel" body line 1)
    invoked from within
"uplevel #0 [list $w invoke active]"
    (procedure "tkMenuInvoke" line 47)
    invoked from within
"tkMenuInvoke .mbar.2.3.menu 1
"
    (command bound to event)}}}

This is probably my fault as I tried to get the job open very shortly after the reboot of PUMA today and I don't think that the UMUI database was properly working. I am able to open my other job xfyc#a.



Change History (4)

comment:1 Changed 9 years ago by nhsavage

I have now copied the job and I seem able to open the copy so this is now very low priority.

comment:2 Changed 9 years ago by ros

Hi Nick,

Could you try opening the job again now?

Ros.

comment:3 Changed 9 years ago by nhsavage

Thanks, it works now.

comment:4 Changed 9 years ago by ros

  • Resolution set to fixed
  • Status changed from new to closed

Note for future reference: this problem was caused by some of the umui2.0/DBSE files being owned by root.

Note: See TracTickets for help on using tickets.