Opened 10 years ago

Closed 9 years ago

#658 closed help (fixed)

Diagnostics only available at surface level?

Reported by: a.elvidge Owned by: um_support
Component: Diagnostics Keywords:
Cc: Platform:
UM Version: 7.6

Description

Hi,

I am attempting to construct grid square theta budgets between surface and a specified height. There are 3 dominant terms: advection, radiation (LW + SW) and turbulent heat flux (sensible heat + latent heat). This requires that I have potential temperature, U, V, W, LW, SW, sensible and latent heat fluxes at surface level and at the specified height (so, on models levels or geometric height or pressure levels). However, after searching high and low in the UM stash, LW, SW, sensible and latent heat fluxes only appear to be available for the surface level. I was wondering whether they could be calculated from other diagnostics (many of which are unrecognisable to me simply from their descriptions) or whether I could write these diagnostics out by making additions to the code in an fcm branch?

Thanks, Andy

Change History (6)

comment:1 Changed 10 years ago by grenville

Andy

It looks like you might need to write your own. I am seeking advice from colleagues, but vacations are slowing the process. I'll get back to you when I have some better advice.

Grenville

comment:2 Changed 10 years ago by grenville

Andy

This advice from the Met Office:

I think from the email sent by Andy that he should try looking at the
temperature increments for model grid boxes. i.e stash diagnostics

1 181 dT due to SW radiation
2 181 dT due to longwave radiation
4 181 dT due to microphysics
5 181 dT due to convection
9 181 dT due to cloud and boundary layer
12 181 dT due to semi-lagraingian advection
30 181 dT total per model timestep

These could be converted to d(theta) using P on model levels.
They could be integrated up to a required height to get the total
heating.

Grenville

comment:3 Changed 10 years ago by grenville

Andy

A couple more comments from the MO:

Stash 3216 is the sensible heat flux on model levels, and 3222 is the
moisture flux, which you can convert to latent heat by multiplying by
2.5e6.

The problem is, these only represent the transport by the BL scheme, the
further you get from the surface the convection scheme will be having a
large effect on the theta budget.

You could of course use the temperature increments from each parametrization
scheme (stash x181) to construct a closed budget - physics schemes don't
adjust the pressure, so they are easy to convert to theta increments.

Ian

Nothing to add to Ian's answer for the science of the question.
From a UM system viewpoint, searching the text of the
vn7.9 STASHmaster_A file from
http://fcm2/projects/UM/export/34627/UMUI/trunk/vn7.9/variables/STASHmaster_A
for the entry
1| 1 | 3 | 216 |BOUNDARY LAYER HEAT FLUXES W/M2|
2| 0 | 0 | 1 | 1 | 1 | 5 | 6 | 0 | 0 | 0 |
1 |
3| 000000000000000000000000000000 | 00000000000110000001 | 3 |
4| 1 | 2 | -3 -3 -3 -3 -14 24 -99 -99 -99 -99 |
5| 0 | 178 | 0 | 65 | 0 | 0 | 0 | 9999 | 33 |
note the "5 | 6" in line 2.
Searching for this string will find you all diagnostics
that are available on Boundary Layer levels.
Though, as you comment, the names, which must mean something
to BL experts, are not always very helpful for the rest of us,
but hopefully they can give you further advice.

Grenville

comment:4 Changed 10 years ago by a.elvidge

Hi Grenville,

Thanks very much, this is of great help. You mention searching for the "5 | 6" string. But how do I access http://fcm2/projects/UM/export/34627/UMUI/trunk/vn7.9/variables/STASHmaster_A ? It appears that I can't simply click on the link.
Also, is it possible to perform a search of the UM stash titles, and if so, where? (I am wondering whether 'emissivity' is available somewhere)

Thanks, Andy

comment:5 Changed 10 years ago by grenville

Andy

The stashmaster files are on hector:

$UMDIR/vn7.X/ctldata/STASHmaster/STASHmaster_A

where X can be one of may versions.

Grenville

comment:6 Changed 9 years ago by ros

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.