Opened 9 years ago

Closed 9 years ago

#668 closed error (fixed)

Automated conversion from pp to netcdf has stopped working

Reported by: cbirch Owned by: um_support
Component: UM Tools Keywords: xconv
Cc: Platform:
UM Version: <select version>

Description

Hi,

I usually convert UM pp files to netcdf using xconv from the commmand line in the serial queue on hector. 'convert' submits it to the queue, 'UM2nc' finds all the pp files in a folder and runs 'pp2nc' on each of them. 'convsh' is called from pp2nc (all scripts are attached).

This method has worked for more than a year. Now when I run pp2nc it just brings up the xconv user interface and then stops. I'm not sure why this is. Has something been changed in xconv in the last week? My scripts were working last Friday (5th August).

Cheers,
Cathryn

Attachments (3)

convert (115 bytes) - added by cbirch 9 years ago.
pp2nc (1.6 KB) - added by cbirch 9 years ago.
UM2nc (276 bytes) - added by cbirch 9 years ago.

Download all attachments as: .zip

Change History (8)

Changed 9 years ago by cbirch

Changed 9 years ago by cbirch

Changed 9 years ago by cbirch

comment:1 Changed 9 years ago by cbirch

convsh was too large to attach so I put it here:
http://homepages.see.leeds.ac.uk/~earceb/for_NCAShelpdesk/

comment:2 Changed 9 years ago by ros

Hi Cathryn,

Nothing has changed with xconv in the last week, as Jeff is away. Has anything changed in your environment, .profile, etc recently, that might be affecting this? Jeff's not back until next week, unfortunately, so I'm not sure what else to suggest.

I'll try and take a look, but this may have to wait until Jeff returns.

Regards,
Ros.

comment:3 Changed 9 years ago by willie

i Cathryn,

The pp2nc in xgife is tiny compared with the one in your ~/bin directory. Perhaps it is corrupt? I am not familiar with pp2nc so can't comment further - where did this program come from?. Also the UM2nc is looking for files that are not actually present in the directory.

There have been no changes to the HECToR xconv for more than a year.

I have tried to use xconv -i <file> -o file.nc to manually convert the files to netcdf and that works fine. So as a last resort you could do this.

Regards,

Willie

comment:4 Changed 9 years ago by cbirch

Hi Ros/Wille?,

pp2nc is just a name for a file taken from this example:
http://www.met.rdg.ac.uk/~jeff/xconv/example2.html

I realise I didn't explain the problem properly. Whilst setting up an example for you I scp'ed copies of convsh and pp2nc that I had on my computer at Leeds over to Hector. These new copies seem to work ok. I think the convsh file I had on Hector had some how become to corrupted.

I'm really sorry to bother you. You can close this ticket now.

Cathryn

comment:5 Changed 9 years ago by willie

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.