Opened 8 years ago

Closed 7 years ago

#679 closed help (fixed)

Running L60 Atmosphere-Only Config of HadGEM2 on Hector

Reported by: watson Owned by: um_support
Component: UM Model Keywords: L60, atmosphere-only, Hector
Cc: Platform: HECToR
UM Version: 6.6.3

Description

I am trying to get HadGEM2 (v. 6.6.3) in its atmosphere-only configuration with 60 vertical levels running on Hector. I have tried two ways of doing this, unsuccessfully:

  1. My job xgigh - I took the example HadGEM2-A L38 job xgadd and tried to vertically extend the model by setting the number of levels to 60 and setting the "location of user defined set" to "vertlevs_strat60" (which is used by the HadGEM2-CC L60 job xgadb) in Atmosphere → Model Resolution → Vertical. I tried both "linear" and "linear with no extrapolation" vertical interpolation options in Atmos → Start dump. This job fails at the reconfiguration stage, giving the error:

Interpolating Field223 ( Section 33 ) ( Stashcode 173 ) Multi-purpose Diagnostic 23

Calculating Exner

ERROR!!! in reconfiguration in routine Rcf_vertical
Error Code:- 10
Error Message:- No interpolation, but data field sizes/levels are different!
Error generated from processor 0

  1. My job xgigi - I took the HadGEM2-CC L60 job xgadb and switched off the ocean submodel, and added the SST and sea ice ancils from the HadGEM2-A L38 job xgadd. The reconfiguration fails with the error message:

Ancillary Files to be opened :

File No 4 Soil Types
File No 9 Land Sea Mask
File No 10 Orography
File No 22 Disturbed fraction of vegetation
File No 26 Land Fraction
File No 27 Dust Soil Properties


rcf_ancil_atmos : nlookups 30


ERROR!!! in reconfiguration in routine Rcf_Calc_Len_Ancil
Error Code:- 1
Error Message:- StashCode? is not a valid prognostic variable
Error generated from processor 0

I would be very grateful if anybody can provide some pointers on how to get the L60 atmosphere-only model running. Also please let me know if there are likely to be any other Physics changes to the above models that need to be made other than extending the lid/turning off the ocean. Thanks in advance for any help you are able to give.

Change History (20)

comment:1 Changed 8 years ago by watson

Just to add a bit more information, I have previously successfully reconfigured an L38 start dump to initiate an L60 HadGEM2-CC model on Monsoon (job xgigg). I have been trying for many hours on Hector with changing various model options, ancil files and start dumps, and getting the same errors as the above depending on whether I am extending the lid or decoupling the ocean.

comment:2 Changed 8 years ago by grenville

Peter

Have you been able to reconfigure an L38 atmosphere-only start dump to 60 levels on MONSooN?

Grenville

comment:3 Changed 8 years ago by watson

Thanks Grenville for the response. I have not got around to trying that with an atmosphere-only start dump on Monsoon - is it likely to be very different to reconfiguring to L60 in a coupled model?

comment:4 Changed 8 years ago by grenville

Peter

Not sure. The only reason I ask is that sometimes running on a different platform exposes problems with the code that aren't apparent otherwise. I am trying to figure out why the reconfiguration is failing on Hector.

Grenville

comment:5 Changed 8 years ago by watson

I will attempt it, but the Monsoon queue seems to be rather slow right now!

comment:6 Changed 8 years ago by grenville

Peter

Please change the permissions for your home and work spaces on Hector so that we can see files in them.

Grenville

comment:7 Changed 8 years ago by watson

Grenville,

I have done so.

Cheers,

Peter

comment:8 Changed 8 years ago by grenville

Peter

I have created a start file for the amip run from the cc run. Please take a look at my job xglaa.
The only changes are to the userstash files, see STASH→User stashmaster files. There you will see several files with the suffix _ignore. Please rerun your job with these files included.

Grenville

comment:9 Changed 8 years ago by watson

Thanks Grenville. I am currently at the NCAS Climate Modelling Summer School and will try running the job when I get the chance.

comment:10 Changed 8 years ago by watson

Hi Grenville - I've starting looking at this again. I made the changes you suggested and tried the reconfiguration step again, but I got the same vertical interpolation error:

Copying Field173 ( Section 0 ) ( Stashcode 511 ) INLANDBASINFLOW ATM GRID KG/M2/S

Calculating Exner
*
ERROR!!! in reconfiguration in routine Rcf_vertical
Error Code:- 10
Error Message:- No interpolation, but data field sizes/levels are different!
Error generated from processor 0
*

I side-stepped this problem by using the start dump you used for xglaa. Now the model starts running, but fails with the following error after a short time:

REPLANCA: UPDATE REQUIRED FOR FIELD 157

REPLANCA - time interpolation for field 157
time,time1,time2 7620. 7200. 7920.
hours,int,period 7620 720 8640
Information used in checking ancillary data set: position of lookup table in dataset: 601
Position of first lookup table referring to data type 1
Interval between lookup tables referring to data type 60 Number of steps 10
STASH code in dataset 135 STASH code requested 351

'Start' position of lookup tables for dataset in overall lookup array 12019
135 351 157

UP_ANCIL : Error in REPLANCA.

*
UM ERROR (Model aborting) :
Routine generating error: UP_ANCIL
Error code: 357
Error message:

REPLANCA: PP HEADERS ON ANCILLARY FILE DO NOT MATCH

*

I tried attaching the full .leave file, but it is a bit over the 256KB limit.

Do you have any suggestions as to what to do?

Cheers,

Peter

comment:11 Changed 8 years ago by grenville

Peter

I shall try to look at this problem this week.

Grenville

comment:12 Changed 8 years ago by grenville

Peter

Please tell me which job this is.

Grenville

comment:13 Changed 8 years ago by watson

The job is xgigh.

Cheers,

Peter

comment:14 follow-up: Changed 8 years ago by grenville

Peter

You are trying to use the file $HG2ES_INPUT/biogenic_351_clim.N96 which is on 38 levels - perhaps ypu should be using HG2CCL60_ancils/biogenic_351_clim.N96L6 which is on 60 levels. Please check that other updating ancillaries have the correct levels

Grenville

comment:15 in reply to: ↑ 14 Changed 8 years ago by watson

Sorry, that was a bad oversight - I thought I had changed all the ancils to their L60 versions. All the rest look to be OK to me.

Running the job after making this change results in the following error, just after the model has started running (xgigh000.xgigh.d11281.t175701.leave):

*

UM WARNING :
Routine generating warning: PRELIM
Warning code: -210
Warning message:
OFFSET DOES NOT AGREE WITH PHENOL PERIOD TS. DIAG IGNORED. (M,S,I) 1 19 7
*

That was for a job that started by reconfiguring /work/n02/n02/grenvill/xglaa/xglaa.astart, since I had been under the impression that the reconfiguration had been successful for that job. But then I also went back to check if making the ancil change fixed the reconfiguration error I had before, by using /work/n02/n02/hum/hg6.6.3/HG2AMIP_ancils/akatda.dak1910 as the start dump. This gave the same error in the reconfiguration as I had before (xgigh000.xgigh.d11281.t193440.leave):

Copying Field173 ( Section 0 ) ( Stashcode 511 ) INLANDBASINFLOW ATM GRID KG/M2/S
Calculating Exner
*
ERROR!!! in reconfiguration in routine Rcf_vertical
Error Code:- 10
Error Message:- No interpolation, but data field sizes/levels are different!
Error generated from processor 0
*

However I noticed the partially output start dump /work/n02/n02/watson/xgigh/xgigh.astart appeared similar to xglaa.astart, which made me think the reconfiguration failed in xglaa, which may be the cause of the errors that occur when the model runs?

In the akatda.dak1910 dump, the fields after no. 173 are tracers, which led me to think the problem may be related to these. Tracer advection is turned off under Atmos → Model config → Tracers, but not under Atmos → Sci params → Section by section → Sec 11, so I turned it off here and also turned off aerosol modelling which depends on this. However, with these turned off, the reconfiguration fails at an even earlier stage than before, in the Rcf_Calc_Len_Ancil routine (xgigh000.xgigh.d11281.t222713.leave).

comment:16 Changed 8 years ago by grenville

Peter

"Running the job after making this change results in the following error, just after the model has started running (xgigh000.xgigh.d11281.t175701.leave):

*

UM WARNING : Routine generating warning: PRELIM Warning code: -210 Warning message: OFFSET DOES NOT AGREE WITH PHENOL PERIOD TS. DIAG IGNORED. (M,S,I) 1 19 7 *

That was for a job that started by reconfiguring /work/n02/n02/grenvill/xglaa/xglaa.astart"

This just indicates a warning and does not tell you why the model failed. In this leave file the lines:

LOOKUP TABLE

191360 64-bit words long

End of rcf program reached. PE 0

indicate that the reconfiguration was OK (although not necessary).

We need more output to help figure out the problem. Please go to Atmosphere→Scinetific..→Section by section..→Diffusion and Filtering, click on DIAG_PRN and select Flush print buffer if run fails. Then rerun.

Grenville

comment:17 Changed 8 years ago by watson

Dear Grenville,

I did so, but no extra output seemed to be generated (xgigh000.xgigh.d11283.t150822.leave).

Cheers,

Peter

comment:18 Changed 8 years ago by grenville

Peter

Please give me read access to /work/n02/n02/watson/xgigh/core.2726 (and .13309, .13339, and .13279)

Thanks

Grenville

comment:19 Changed 8 years ago by watson

Done.

Cheers,

Peter

comment:20 Changed 7 years ago by ros

  • Platform set to HECToR
  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.