Opened 10 years ago

Closed 10 years ago

#691 closed help (fixed)

UMUI crashes on submitting

Reported by: eelgc Owned by: um_support
Component: UM Model Keywords: ssh, UMUI
Cc: Platform:
UM Version: <select version>

Description

Hi,

I'm trying to submit a fairly standard global run (job xglma). When submitting I get the window which gets as far as this:

Calling FCM_MAIN_SCR - local…
(This may take several minutes)

FCM_MAIN: Calling Extract …
Base extract: OK
Model extract: OK
Reconfiguration extract: OK
FCM_MAIN: Extract OK

FCM_MAIN: Submitting umuisubmit_clr …

After this it just freezes and UMUI becomes unresponsive.

Thanks for your help,

Luis

Change History (5)

comment:1 follow-up: Changed 10 years ago by willie

  • Keywords ssh, UMUI added

Hi Luis,

I suspect that your ssh agent has stopped. You should cd into the directory .ssh (note the dot) and delete the file environment.puma. Then logout and log back in again. See #686.

Regards,

Willie

comment:2 in reply to: ↑ 1 Changed 10 years ago by eelgc

Hi,

you're right. I hadn't setup the ssh properly at all, I followed the instructions on the link you gave in the previous ticket, and the problem is solved.

Unfortunately I get another problem. I get the following message:

FCM_MAIN: Submitting umuisubmit_clr …
qsub: script file:: No such file or directory
FCM_MAIN: Submit failed

PathScale? PrgEnv? loaded
xtpe-network-gemini
PrgEnv?-pathscale/3.1.49A
xt-mpt/5.3.0
pathscale/3.2.99
xtpe-mc12
umui_runs/xglma-256182020/SUBMIT[19]: .: /work/n02/n02/hum/vn7.3/pathscale/scripts/.umsetvars_7.3: cannot open [No such file or directory]

I can see that the path is wrong (the folder pathscale should be pathscale_quad) but I can't find where to change this path. Looking into the file it says it's called in a UMUI script called SCRIPT, but again I don't know where that is.

Thanks for your help!

Luis

Replying to willie:

Hi Luis,

I suspect that your ssh agent has stopped. You should cd into the directory .ssh (note the dot) and delete the file environment.puma. Then logout and log back in again. See #686.

Regards,

Willie

comment:3 follow-up: Changed 10 years ago by willie

Hi Luis,

In your .profile you should have lines like

UMDIR=/work/n02/n02/hum
TARGET_MC=pathscale_quad

VN=7.6; export VN
UMSETUP=$UMDIR/vn${VN}/$TARGET_MC/scripts/.umsetvars_${VN} ; export UMSETUP

I think you must have "pathscale" instead of "pathscale_quad".

Regards,

Willie

comment:4 in reply to: ↑ 3 Changed 10 years ago by eelgc

Hi,

that did the trick. Thanks a lot.

Luis

comment:5 Changed 10 years ago by willie

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.