Opened 9 years ago

Closed 9 years ago

#694 closed help (fixed)

Segmentation Error.

Reported by: mhollaway Owned by: um_support
Component: UM Model Keywords: Segmentation Error, UM Model Crash
Cc: Platform:
UM Version: 6.6.3

Description

Hello,

I am currently experiencing some errors in trying to get a version (6.6.3) of HadGEM2-A running on Monsoon, based on a Met Office basis file. I am running a reconfiguration first (on the same numebr of processors I am running the UM on) and have managed to get the model to run successfully for 10 days and produce sensible output. However when I try to increase the run time to 1 month, the model crashes producing the following error.

/projects/ukca/mhollo/xfsak/bin/qsexecute: Executing setup

/projects/ukca/mhollo/xfsak/bin/qssetup: Job terminated normally

/projects/ukca/mhollo/xfsak/bin/qsexecute: Executing dump reconfiguration program

*
RCF Executable : /projects/ukca/mhollo/xfsak/bin/qxreconf
*

/projects/ukca/mhollo/xfsak/bin/qsexecute: Executing model run

*
UM Executable : /projects/ukca/mhollo/xfsak/bin/xfsak.exe
*

/projects/ukca/mhollo/xfsak/bin/qsexecute[814]: assign: not found.
ERROR: 0031-250 task 0: Segmentation fault

Could the error possibly linked to an error in one of the model fields that causes it to crash when I run for longer periods of time.

Many thanks.

Michael Hollaway.

Change History (3)

comment:1 Changed 9 years ago by ros

Hi Michael,

Could you try turning off "Automatic post processing" in UMUI window sub-indep → Post Processing → Main switch and see if that fixes the problem?

Regards,
Ros.

comment:2 Changed 9 years ago by mhollaway

Hi Ros,

Many thanks for your reply. I have tried that and the model now appears to run fine for a month. I have also managed to find an error with me having overlooked a switch in the LW radiation scheme which I had on the wrong setting and may have been causing a segmentation error in one of the LW radiation scheme arrays. I have changed this switch and turned the automatic post processing back on and the model now runs fine for the full month and produces sensible output. Im guessing this was possibly what was causing the original segmentation fault?

Many thanks again for your help, its much appreciated.

Best regards,

Michael.

comment:3 Changed 9 years ago by ros

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.