Opened 9 years ago

Closed 9 years ago

#697 closed help (fixed)

Climate Meaning Error

Reported by: swr07dmm Owned by: um_support
Component: UM Model Keywords:
Cc: Platform:
UM Version: 6.6.3

Description

Hi, I've managed to get a version of HadGEM2-ES running on HECToR (id: xgklb) however it throws up an error when I include "Define a Meaning Sequence" in the ocean GCM. While I can run the model without using this, I am unsure it there is a hidden error somewhere which I should know about, and that might cause problems down the line with output or otherwise.

Is there any way of understanding why it will not work with this switched on?

Man thanks,
Dann

Change History (6)

comment:1 Changed 9 years ago by ros

Hi Dann,

If you look near the bottom of your job output you will see that the problem is with a specific diagnostic. If you turn off the following ocean diagnostic in STASH

Section:0 Item: 120 OT18: DIATOM-CHLORO: CFC12; EXTRA-C

then hopefully it will then work. This diagnostic is know to cause problems on HECToR and we switched it off in all the HadGEM2 standard jobs.

Regards,
Ros.

comment:2 Changed 9 years ago by swr07dmm

Hi Ros, thanks that worked fine.

Sorry to bother you with another question, but I'm trying to get a job from monsoon working on hector, its a version of HadGEM2 and I know you successfully did this with the control run of the same model (your model ID was xgadb I think).

The problem I have is that I want to copy over a transient run, not the control. The main barrier I am coming across is the 'table user modifications' - all the fcm stuff. How is best to copy this from monsoon to hector?

Many thanks,
Dann

comment:3 Changed 9 years ago by ros

Hi Dann,

You don't need to worry about any of the user modification fcm branches. They are stored on PUMA and are available to both MONSooN and HECToR jobs without the need for any modifications. Just make sure you have added in the fcm:um_br/pkg/Config/HG6.6.3_ncas/src branch and the fixes branch fcm:um_br/dev/ros/HG6.6.3_fixes/src to pick up HECToR specific modifications.

Further info on converting a MONsooN job to run on HECToR is also available on the CMS website:
http://cms.ncas.ac.uk/index.php/um-faq/1542-convert-monsoon-job-to-hector

Hopefully that will answer any questions, but if not just ask.

Cheers,
Ros.

comment:4 Changed 9 years ago by swr07dmm

Thanks Ros,

I've used the same FCM setup for my HECToR job as in my MONSooN job, but the HECToR job did not manage to compile properly. The HECToR job ID is xgklb and the .leave file is /home/n02/n02/dmitch/um/umui_out/xgklb000.xgklb.d11271.t140029.comp.leave . It looks to me as if it is FCM related, but I can't be sure.

For reference, the MONSooN job that was working with this FCM config is xfwnl.

Many thanks,
Dann

comment:5 Changed 9 years ago by ros

Hi Dann,

That calc_div_ep_flux.F90 error is a complete pain. Unfortunately that file was added in by a HG6.6.3 branch. I fixed it in all the standard jobs and had hoped that all Met Office jobs introduced the calc_div_ep_flux file by using the same branch, but it appears they don't. :-(

In your job the calc_div_ep_flux file is added by the branch
fcm:um_br/dev/steven.hardiman/HG6.6.3_fixtem2

The compiler error is because 4 variables have not been explicitly declared. MONSooN doesn't seem to mind, but HECToR complains.

I would recommend asking Steven if he could add the following bit of code to calc_div_ep_flux in his HG6.6.3_fixtem2 branch.

! Local Variables 
      INTEGER x, y, z, top 

This will be the easiest solution and will also mean that the same branch can be used by both MONSooN and HECToR jobs, rather than having to remember to change the fcm branch in the job when moved from MONSooN to HECToR.

Regards,
Ros.

comment:6 Changed 9 years ago by ros

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.