Opened 9 years ago

Closed 8 years ago

#703 closed help (fixed)

Help with HG6.6.3 code modification - conflict resolution?

Reported by: peterh Owned by: ros
Component: FCM Keywords: clash
Cc: Platform:
UM Version: 6.6.3

Description

Hi, I'm trying to modify the values of 2 parameters in the dust_src routine. I've done this using the create_HG2_branch command on puma. However, the UMUI doesn't like my revision (peterh/HG6.6.3_dustpars/src number 7663) and I get an error when I try to submit this job.

The only reason I could see, is that this subroutine has already been previously modified, but I wasn't sure how to get around this or whether this matters for HG2 setup.

thanks

Change History (4)

comment:1 Changed 9 years ago by ros

  • Keywords clash added
  • Status changed from new to accepted

Hi Peter,

Yes you are correct that the problem is due to a clash between branches. I assume this is job xglid that you are referring to? Unfortunately, the level of extract output is turned down so I can only see in $HOME/um/um_extracts/xglid/umbase/ext.out that the problem is with the dust_srce file, but you say you can see it's been modified in another branch too.

To overcome this you will need to merge the other branch that has modified the dust_srce routine into your peterh/HG6.6.3_dustpars branch and then manually resolve the conflict.

The basic method of doing this is as follows:

1) cd to your HG6.6.3_dustpars working copy on PUMA
2) Run the fcm command  "fcm merge fcm:um_br/path/to/other/branch".  This will attempt to merge in the other branch's changes.  It will flag the conflict in dust_srce and ask you what you want to do.  Enter "p" to postpone.
3) Run the command "fcm conflicts".  This will bring up the tool xxdiff.  In the top right hand corner there will be a number which details the number of conflicts that need to be resolved.  

Since I don't know which other branch it's clashing with I can't give you the exact instructions, but if you follow the example in the UM Tutorial (http://puma.nerc.ac.uk/trac/UM_TUTORIAL/wiki/UmTutorial/vn7.1/ResolvingConflicts) hopefully it will be straightforward.

If it doesn't make sense or is more complicated, then let me know which branches are clashing and I'll take a look and guide you through it.

Regards,[br?
Ros.

comment:2 Changed 9 years ago by peterh

Hi,
I've tried doing the merge command, but I can't work out which branch I need to merge with. Is there a way to get this ouput in the ext.out file?

thanks

comment:3 Changed 9 years ago by ros

Hi Peter,

In UMUI window sub-independent→FCM Configuration → FCM Options
There is a button to set the level of output for the Extract. Set it to level 3 and submit the job again.

Cheers,
Ros.

comment:4 Changed 8 years ago by ros

  • Resolution set to fixed
  • Status changed from accepted to closed

No further comments have been made to this ticket so it is now being closed.

Please contact the helpdesk if you have further queries.

Note: See TracTickets for help on using tickets.