Opened 9 years ago

Closed 9 years ago

#709 closed error (fixed)

Cannot add diagnostics to STASH panel due to error in menu system

Reported by: cbirch Owned by: um_support
Component: UMUI Keywords: STASH
Cc: Platform:
UM Version: 6.1

Description

Hi,

I'm trying to add some diagnostics to a UM job (xfxsd). I am unable to select anything from section 0 in the 'load new diagnostics' menu because when the menu opens I get this error:

ERROR: Unexpected STASH option code st_mask_n(5)=3. Model A. Section 0.

If I click on 'stack trace' I get:

ERROR: Unexpected STASH option code st_mask_n(5)=3. Model A. Section 0.
STACK-TRACE:
Unexpected STASH option code st_mask_n(5)=3. Model A. Section 0.

while executing

"error "Unexpected STASH option code st_mask_n(5)=$st_mask_n(5). Model A. Section $isec.""

(procedure "check_section_A_0" line 59)
invoked from within

"check_section_A_0 0"

("eval" body line 1)
invoked from within

"eval "check_section_$model_letter\_$isec $isec" "

(procedure "check_stash" line 104)
invoked from within

"check_stash $section $item $mNumber"

(procedure "getSection" line 39)
invoked from within

"getSection $sTable 0 0 $mNumber"

(procedure "loadNewDiags" line 65)
invoked from within

"loadNewDiags 1"

invoked from within

".stash_A.#stash_A#menubar.#stash_A#menubar#mb2 invoke active"

("uplevel" body line 1)
invoked from within

"uplevel #0 [list $w invoke active]"

(procedure "tkMenuInvoke" line 47)
invoked from within

"tkMenuInvoke .stash_A.#stash_A#menubar.#stash_A#menubar#mb2 1
"

(command bound to event)

I am not really sure what is causing this. I can access the diagnostics in the other sections, its just section 0 that is causing a problem. The same problem also occurs for job xfxsa and xfxse. I copied these jobs from the xfbv experiment and I had no problems there.

Cheers,
Cathryn

Change History (3)

comment:1 Changed 9 years ago by willie

  • Keywords STASH added

Hi Cathryn,

The cause is the user STASH 6.1_for_2011. If you switch this off the problem will disappear. Do you need all the entries in this file?

Regards,

Willie

comment:2 Changed 9 years ago by cbirch

Hi,

Thanks, I would not have worked out that it was that file that was causing the error.

I need all the entries in that file because I created it so the vn6.1 job would except the 2011 start dump.

If found that if I temporarily turned off all the user STASHmaster files, added the diagnostics I need from section 0 in the STASH panel and then turned the STASHmaster files back on it works fine.

Thanks for you help,

Cathryn

comment:3 Changed 9 years ago by willie

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.