Opened 9 years ago

Closed 9 years ago

#744 closed help (fixed)

Job failed - error in setup step

Reported by: eelsj Owned by: um_support
Component: UM Model Keywords:
Cc: Platform:
UM Version: 6.6.3

Description

Hi

Using umui I have submitted my job(xgroa using model version 6.6.3) to Hector. It compiles (I think) but fails when beginning to execute giving me the following messages in the .leave file:

Job started at : Tue Nov 22 17:26:43 UTC 2011

Run started from UMUI
Running from control files in /home/n02/n02/eelsj/umui_runs/xgroa-326152509

HadGEM2-CC L60 r1.1 (akxva) - XE6 (from lois)
This job is running on machine hector-xe6-14,
using UM directory /work/n02/n02/hum,
/var/spool/PBS/mom_priv/jobs/443349.sdb.SC[303]: .[170]: .[91]: /work/n02/n02/eelsj/xgroa/xgroa.out: cannot create [No such file or directory]

/work/n02/n02/hum/hg6.6.3/cce/scripts/qsexecute: Executing setup

/work/n02/n02/hum/hg6.6.3/cce/scripts/qssetup[89]: /work/n02/n02/eelsj/xgroa/xgroa.out: cannot create [No such file or directory]
/work/n02/n02/hum/hg6.6.3/cce/scripts/qssetup: Job failed
/work/n02/n02/hum/hg6.6.3/cce/scripts/qsexecute: Error in setup step
*

Ending script : qsmaster
Completion code : 135
Completion time : Tue Nov 22 17:26:43 UTC 2011

*

/work/n02/n02/hum/hg6.6.3/cce/scripts/qsmaster: Failed in qsmaster in model xgroa

<<<< Information about How Many Lines of Output follow >>>>

wc: /work/n02/n02/eelsj/xgroa/xgroa.out: No such file or directory

lines in main OUTPUT file.

0 lines of O/P from pe0.

I have checked my run setup but can't see what's wrong.

Thank you

Change History (5)

comment:1 follow-up: Changed 9 years ago by ros

Hi Lawrence,

Can you change the permissions on your /home and /work directories so that we can read them please?

chmod -R g+rx /home/n02/n02/eelsj
chmod -R g+rx /work/n02/n02/eelsj

Cheers, Ros.

comment:2 in reply to: ↑ 1 Changed 9 years ago by eelsj

Hi Ros

Done

Lawrence

Replying to ros:

Hi Lawrence,

Can you change the permissions on your /home and /work directories so that we can read them please?

chmod -R g+rx /home/n02/n02/eelsj
chmod -R g+rx /work/n02/n02/eelsj

Cheers, Ros.

comment:3 Changed 9 years ago by ros

Hi Lawrence,

You need to change the line

UMSETUP=$UMDIR/vn6.6/$TARGET_MC/scripts/.umsetvars_6.6; export UMSETUP

in your HECToR $HOME/.profile to be

UMSETUP=$UMDIR/hg6.6.3/$TARGET_MC/scripts/.umsetvars_6.6.3; export UMSETUP

This sets up specific environment variables needed by the UM run. The one you had in there previously doesn't exist.

You will need to submit the job to compile again in order for the system to create the relevant directories and copy the required job scripts/executables to the correct location in preparation to run. If you turn off "Force full extract" and "Force full build" in the UMUI window submodel indep → FCM config → FCM config variables it will do an incremental compile which will be quick.

Regards,
Ros.

comment:4 Changed 9 years ago by eelsj

Hello Ros,

Thank you for your help. My run appears to have successfully executed!

Regards,
Lawrence

comment:5 Changed 9 years ago by ros

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.