Opened 12 years ago

Closed 12 years ago

#76 closed help (fixed)

Error in COEX

Reported by: hanneke Owned by: um_support
Component: UM Model Keywords:
Cc: Platform:
UM Version:

Description

Hello,

I had a run working but realized I was using the wrong land mask. I changed this (and the number of land points), reran the reconfiguration (I do this in a separate run) and ran the same run again. I have used this land mask before and it didn't give me any problems. However, my run is now failing with this error:

GATHER_FIELD: Message: GATHER_FIELD: Error in COEX

STASH_GATHER_FIELD : Failed during GATHER_FIELD
Error code : 2
Message : GATHER_FIELD: Error in COEX
Error occured in STASH while gathering data for output.
STASH : Error processing diagnostic section 3 , item 209 , code 2

Failed to gather field

RHS zero so GCR( 2 ) not needed
==============================================

GATHER_FIELD: Non-Zero Error Code 2
GATHER_FIELD: Message: GATHER_FIELD: Error in COEX
STASH_GATHER_FIELD : Failed during GATHER_FIELD
Error code : 2
Message : GATHER_FIELD: Error in COEX
Error occured in STASH while gathering data for output.
STASH : Error processing diagnostic section 16 , item 204 , code 2

Failed to gather field

*
UM ERROR (Model aborting) :
Routine generating error: Atm_Step
Error code: 2
Error message:

Failed to gather field
Ad÷ÈOÿÿÿþèCXOÿÿÿþèkXOÿÿÿÿþz OÿÿÿþâÖp?A¢P
AP1%P
APÃzHOÿÿÿþâ×@

*

What is this COEX? I've tried to make changes in the STASH to exclude those items, but then it just gives the same problem with a different item. Does anyone know where this error comes from?

Thanks a lot!
Hanneke

PS Have attached the basis file for the job in case you need it.

Attachments (1)

basis_xcmyf (138.9 KB) - added by hanneke 12 years ago.

Download all attachments as: .zip

Change History (5)

Changed 12 years ago by hanneke

comment:1 Changed 12 years ago by lois

Hello Hanneke, sorry for the delay in replying, there are a few people on holiday at the moment! Jeff who is on holiday would probably be able to answer more precisely but I think I understand where the problem occurs but not necessarily why it fails and causes a problem.

Firstly COEX is the routine that does the packing and unpacking of the data. So in the UMUI if you go to submodelindependent → postproecssing → initialisation and processing you will see that you are asking for some output channels to be packed as for operational output streams and these are what are using COEX.

I don't yet see why this packing doesn't work but firstly it would be interesting to know why you are using this packing? Did you have this packing on in other jobs, that you say worked?

You may want to try a bit of experimentation like turning off packing and see if this works. If it is the cause of your problem please let me know and I will inititate an investigation.

Lois

comment:2 Changed 12 years ago by hanneke

Hi Lois,

Thanks for your help! I have no idea why the packing was turned on! I checked and I have used these settings for all my runs so far, it must have been set like this in the basic run I used.

I turned the packing off and reran the same run. It did finish this time and doesn't give any error messages but unfortunately the output looks corrupt. I have looked into more detail and found these lines in the .leave file:

==============================================

Atm_Step: Timestep 1184

RHS zero so GCR( 2 ) not needed

==============================================

(several times)

I've had this before and Chang told me it usually means something is wrong with the ancillary files or a field somewhere has invalid values. She said it could also be caused by too steep orography at the boundaries. I have used the LBC's, ancillary files and start dumps before successfully though, so no idea why it's causing a problem this time.

I'll work on it, but if you have any ideas on what's going wrong, let me know!

Many thanks,
Hanneke

comment:3 Changed 12 years ago by hanneke

Hello again,

I have now managed to find the cause of the problem - one of the ancillary files was not set to the right filename!

Thanks a lot for the help, you can close this ticket now.
Cheers,
Hanneke

comment:4 Changed 12 years ago by ros

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.