Opened 9 years ago

Closed 9 years ago

#770 closed help (fixed)

problem with the ssh agent on Puma to Monsoon

Reported by: cplanche Owned by: ros
Component: PUMA Keywords: SSH
Cc: Platform:
UM Version:

Description

Hi,

I don't know why but I loose my ssh-agent on puma.
So to install again the ssh-agent, I follow the "SSH Setup on MONSooN" webpage. Nevertheless, I can't add the public key to the ~/.ssh/authorized_keys file on PUMA.The error message that appears is:

cplanche@puma:~> cat /home/cplanche/.ssh/id_dsa.pub >> /home/cplanche/.ssh/authorized_keys
-bash: /home/cplanche/.ssh/authorized_keys: Permission denied

What is the problem?
Many thanks

Regards,
Celine

Change History (5)

comment:1 follow-up: Changed 9 years ago by ros

  • Keywords SSH added
  • Owner changed from um_support to ros
  • Status changed from new to accepted
  • UM Version <select version> deleted

Hi Celine,

I can't see your .ssh directory due to the permissions, but I guess that the permissions of your /home/cplanche/.ssh/authorized_keys file is read-only. If this is so change the permission to allow yourself write access.

chmod u+w authorized_keys

Regards,
Ros.

comment:2 in reply to: ↑ 1 Changed 9 years ago by cplanche

Hi Ros,

I changed the file permission and completed the setting up ssh-agent on PUMA. Nevertheless, when I run the ssh-add command, I have the following error message:

cplanche@puma:~> ssh-add
Could not open a connection to your authentication agent.

Regards,
Celine

comment:3 follow-up: Changed 9 years ago by ros

Hi Celine,

This I believe is the underlying problem and caused the ssh failure initially.

You need to remove the file /home/cplanche/.ssh/environment.puma on PUMA and then log out and log back in again. You will hopefully see a message something along the lines of "re-initialising ssh-agent", you should then be able to run ssh-add successfully.

Regards,
Ros.

comment:4 in reply to: ↑ 3 Changed 9 years ago by cplanche

Hi Ros,

Thanks. The ssh-agent works now.

Regards,
Celine

comment:5 Changed 9 years ago by ros

  • Resolution set to fixed
  • Status changed from accepted to closed

Hi Celine,

Glad it's all working again. If you ever get problems with the ssh-agent having apparently died again (sometimes the agent just stops running or gets disconnected). Just try removing the environment.puma file logging out and back into puma and re run ssh-add. This usually fixes the problem and is much easier than going through the chore of recreating the keys, etc.

Cheers, Ros.

Note: See TracTickets for help on using tickets.