Opened 9 years ago

Closed 9 years ago

#772 closed help (fixed)

problem with xancil/ff2pp

Reported by: anmcr Owned by: jeff
Component: UM Tools Keywords:
Cc: Platform:
UM Version: <select version>

Description

Hi, this is probably for Jeff.

I used xancil to produce 4 ancillaries which are labelled 'byte swapped 64 bit ieee um file' (output from xconv). They are located at /home/n02/n02/anmcr/work/UMAncil/CLIM/mweeks.

I want to convert them to 32 bit pp files, and did this previously by running 'ff2pp -ieee64bs .le.pp' followed by 'bigend -32 .le.pp .pp'.

Now, however, when I run the 'ff2pp' step I get the error message 'OFCAP_4km_extended_orog is not a UM fieldsfile, FIXHD(5)=4'.

I would be grateful of some help.

Thanks,

Andrew

Change History (3)

comment:1 Changed 9 years ago by jeff

  • Owner changed from um_support to jeff
  • Status changed from new to accepted

Hi Andrew

ff2pp is only designed to work with UM fields files not ancillary files. Use um2pp instead, it should work in exactly the same way.

Jeff.

comment:2 Changed 9 years ago by anmcr

Hi Jeff,

Thank you very much. um2pp worked perfectly.

Best wishes,

Andrew

comment:3 Changed 9 years ago by jeff

  • Resolution set to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.