Opened 9 years ago

Closed 9 years ago

#777 closed help (fixed)

HG6.6.3 Compliing on Hector - cannot locate config file

Reported by: eelsj Owned by: willie
Component: UM Model Keywords: SSH
Cc: Platform:
UM Version: 6.6.3

Description

Dear Helpdesk,

My model XGTED fails when submitted to Hector from UMUI. The .comp.leave file (xgted000.xgted.d12023.t121431.comp.leave) gives the following message:

[FAIL] /home/n02/n02/eelsj/xgted/umbase/cfg/bld.cfg: cannot locate config file, abort at /esfs1/n02/n02/hum/fcm/bin/../lib/Fcm/ConfigSystem.pm line 526

Build command started on Mon Jan 23 12:20:21 2012.
→Parse configuration: start
Base build: failed

Looking at the /home/n02/n02/eelsj directory, no xgted subdirectory was created.

Can you help, please? Thank you.

Lawrence Jackson

Change History (5)

comment:1 Changed 9 years ago by willie

  • Owner changed from um_support to willie
  • Status changed from new to accepted

Hi Lawrence,

It looks like you have run out of space on your home disk, where you are trying to build xgted. You should delete some directories and try again.

Regards,

Willie

comment:2 Changed 9 years ago by eelsj

Hi Willie,

I deleted a number of directories in /home/n02/n02/eelsj reducing my disk quota from about 2900000 to 2180480 (as reported by 'quota -u eelsj').

I still get the same error message in xgted000.xgted.d12023.t145046.comp.leave
when I submit XGTED for compiling:

[FAIL] /home/n02/n02/eelsj/xgted/umbase/cfg/bld.cfg: cannot locate config file, abort at /esfs1/n02/n02/hum/fcm/bin/../lib/Fcm/ConfigSystem.pm line 526

Build command started on Mon Jan 23 14:55:25 2012.
→Parse configuration: start
Base build: failed

Do I need to delete more files? I looks to me that I have plenty of disk capacity if I am interpreting the outputs of 'quota -u eelsj' correctly.

Thanks

Lawrence

comment:3 Changed 9 years ago by willie

Hi Lawrence,

If you look in the ext.out file for this job on PUMA, you will see that it is failing to create the directory to put the bld.cfg file in. This is due to an SSH problem. If you do

ps -u eelsj

is the ssh-agent running? If not, you will have to delete your .ssh/environment.puma file, and login PUMA again. Then remember to do an ssh-add and submit your job again.

Regards,

Willie

comment:4 Changed 9 years ago by eelsj

Hi Willie,

Thank you. That's cured the problem.

Lawrence

comment:5 Changed 9 years ago by willie

  • Keywords SSH added
  • Resolution set to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.