Opened 8 years ago

Closed 8 years ago

#818 closed help (fixed)

Problem for create a new branch on the trac

Reported by: cplanche Owned by: ros
Component: Trac Keywords:
Cc: Platform:
UM Version:

Description (last modified by ros)

Hi,

I would like to create a new branch on the trac. I already ask a ticket but when I write the fcm command to create a new branch my password and username are requested.
After three tries, it fails. However, I am sure about my password and username (I can connect to the trac). The error message is:

cplanche@puma:~> fcm branch -c -n ukca_lam_idealised --revision vn8.0 --type dev -k 393 fcm:um_tr[[BR]]
Starting xterm -e vi to edit commit message ...[[BR]]
Change summary:[[BR]]
--------------------------------------------------------------------------------[[BR]]
A    svn://puma/UM_svn/UM/branches/dev/cplanche/VN8.0_ukca_lam_idealised[[BR]]
--------------------------------------------------------------------------------[[BR]]
Commit message is as follows:[[BR]]
--------------------------------------------------------------------------------[[BR]]
Created /UM/branches/dev/cplanche/VN8.0_ukca_lam_idealised from /UM/trunk@7466.[[BR]]
Relates to ticket #393.[[BR]]
--------------------------------------------------------------------------------[[BR]]
Would you like to go ahead and create this branch?[[BR]]
Enter "y" or "n" (or just press <return> for "n"): y[[BR]]
Creating sub-directory: branches/dev/cplanche[[BR]]
Authentication realm: <svn://puma:3690> 8ca64e62-1750-0410-b9b8-f1ff413d6028[[BR]]
Password for 'cplanche':[[BR]]
Authentication realm: <svn://puma:3690> 8ca64e62-1750-0410-b9b8-f1ff413d6028[[BR]]
Username: cplanche[[BR]]
Password for 'cplanche':[[BR]]
Authentication realm: <svn://puma:3690> 8ca64e62-1750-0410-b9b8-f1ff413d6028[[BR]]
Username: cplanche[[BR]]
Password for 'cplanche':[[BR]]
svn: Authentication error from server: Password incorrect[[BR]]
svn mkdir -m 'Created branches/dev/cplanche directory.' svn://puma/UM_svn/UM/branches/dev/cplanche failed (1) at /home/um/fcm/bin/../lib/Fcm/CmBranch.pm line 840[[BR]]

If I well remember, I already create a branch when I made the UM-FCM tutorial and I didn't have this problem.

Many thanks.

Celine

Change History (2)

comment:1 Changed 8 years ago by ros

  • Description modified (diff)
  • Status changed from new to accepted
  • UM Version <select version> deleted

Hi Celine

The first time you write to a subversion repository it asks for a password. Once you've done this once it caches your settings and won't prompt for a password for commits on that repository again. This would have happened for the tutorial repository too, but the UM and tutorial repositories are separate so it has to be done again.

Just hit "Return" or add the option —password ""

Cheers,
Ros.

comment:2 Changed 8 years ago by ros

  • Resolution set to fixed
  • Status changed from accepted to closed

Since there has been no activity on this ticket for 2 weeks, it is assumed that the solution provided has fixed the problem. Please reopen this ticket if this is not the case and you have further queries.

Note: See TracTickets for help on using tickets.