Opened 8 years ago

Closed 8 years ago

#819 closed help (fixed)

SST ancillary

Reported by: rhossaini Owned by: willie
Component: UM Model Keywords: ancillary
Cc: Platform:
UM Version: 7.3

Description

Hi,

I was wondering if you could help please..

I am trying to perform an N48 L60 UKCA (UM7.3) run and with a new SST ancillary. The job is xgfyx.

Sadly, the new ancillary is causing a segmentation fault. In the .leave file I get:

_pmiu_daemon(SIGCHLD): [NID 00318] [c2-0c1s0n0] [Thu Mar 15 17:06:41 2012] PE RANK 33 exit signal Segmentation fault
_pmiu_daemon(SIGCHLD): [NID 00319] [c2-0c1s0n1] [Thu Mar 15 17:06:41 2012] PE RANK 48 exit signal Segmentation fault
_pmiu_daemon(SIGCHLD): [NID 02669] [c3-1c2s6n1] [Thu Mar 15 17:06:41 2012] PE RANK 2 exit signal Segmentation fault
[NID 00318] 2012-03-15 17:06:41 Apid 1786386: initiated application termination
diff: /work/n02/n02/elrh/tmp/tmp.hector-xe6-14.16446/xgfyx.xhist: No such file or directory
qsexecute: Copying /work/n02/n02/elrh/um/xgfyx/xgfyx.thist to backup thist file /work/n02/n02/elrh/um/xgfyx/xgfyx.thist_keep
xgfyx: Run failed

I'm fairly new to the UM and am not sure what is going wrong here.

The ancillary was created from higher resolution data. The original data had missing values over land and so I first extrapolated over these points in xconv (before the regrid).

The ancillary that seems to be causing the crash is here:

/work/n02/n02/elrh/ANCILS/TEST2/fextrap

Any help much appreciated, thanks,

Ryan

Change History (11)

comment:1 Changed 8 years ago by willie

  • Owner changed from um_support to willie
  • Status changed from new to accepted

Hi Ryan,

You have asked for your SST's to be updated daily, but the file only has monthly data.

Regards,

Willie

comment:2 Changed 8 years ago by rhossaini

Hi Willie,

Thanks for your response.

I have corrected that now but I don't think that is the problem.

I have rerun and am still getting a segmentation fault. The .leave file is:

/home/n02/n02/elrh/um/umui_out/

xgfyx000.xgfyx.d12076.t093608.leave

My previous SST ancillary which works is:

sst_2000_anc

in /home/n02/n02/elrh/work/ANCILS/2000/

Just changing from this file is causing the issue.

Thanks,

Ryan

comment:3 Changed 8 years ago by willie

Hi Ryan,

The ancillary looks ok to me. You could do a Job > Difference in the UMUI with the job that uses sst_2000_anc. Other things I noted were that the job is unstable in the first time step

GCR( 2 ) failed to converge in 100 iterations.

and that there is a check setup error in Post processing page where the archiving is set up, but I couldn't locate the problem myself.

Regards

Willie

comment:4 Changed 8 years ago by rhossaini

Hi Willie,

Thanks for looking at this. The instability is hopefully now sorted. The new job is xgfyy.

I'm wondering if there is some kind of inconsistency between the new SST and also sea-ice ancils. The latest versions are:

/home/n02/n02/elrh/work/ANCILS/TEST3/ryan_sst

and /home/n02/n02/elrh/work/ANCILS/TEST3/ice1

These files are for 2100 (RCP8.5) and there is significantly less sea-ice. I'm not sure if this could be an issue with the initial field in the start dump or not.

I have found that changing the new SST (and also sea ice) ancillary to be 'configured' rather than 'updated' removes the segmentation fault and thus the model runs. The new fields seem to have been put into the the astart file - xgfyx.astart

I have set a new run going that uses this new start dump but with SSTs and sea ice back to 'updated'.. I'm hoping that will sort it but wonder if this is a sound thing to do?

Anyway this run also causes a segmentation fault.

The .leave file is:

/home/n02/n02/elrh/um/umui_out/xgfyy000.xgfyy.d12080.t161529.leave

Thanks,

Ryan

comment:5 Changed 8 years ago by willie

Hi Ryan,

Can you give me read permission on the core file in /work/n02/n02/elrh/um/xgfyy? The following are the current issues

  • There is a check setup error in Post processing > main switch. If you select "No archive" this will go away
  • There are errors on the STASH page - if you do a Ctl V you will see them
  • the model is still unstable GCR(2) failed to converge - you can see this in the .leave file

regards

Willie

comment:6 Changed 8 years ago by rhossaini

Hi Willie,

I have now selected the "No archive" option and have re run the model.

I am looking in to the STASH errors. These don't appear to be the cause of the problem though as they are present in other runs.

For the 'GCR(2) failed to converge' error, I can only assume that is to do with the current problem. My other jobs with the old SST ancil did not have this.

The core file should now have read permissions.

Thanks,

Ryan

comment:7 Changed 8 years ago by willie

Hi Ryan,

I still can't read the core file - try chmod 644 on it.

There is a problem with your hand edit add_s34_Ches_tracers_L60.ed - you can see it if you press 'process' on the UMUI

Regards,

Willie

comment:8 Changed 8 years ago by rhossaini

Hi Willie,

Thanks, I will look at the hand edit.

I have done the chmod 644 - hopefully that should work now.

Ryan

comment:9 Changed 8 years ago by willie

Thanks Ryan, The core file, although older than the executable, indicates that there may be a problem in subroutine ukca_calc_tropopause. You can delete the core file now, but we may need to look at this again when the other errors are eliminated.

You should just switch off the STASH items that are in error. Always do a Ctl-V on the STASH page, before running.

Regards,

Willie

comment:10 Changed 8 years ago by rhossaini

Hi Willie,

This ticket can be closed now as the issue seems to be resolved.

The SST and sea-ice ancils have been recreated and the model now runs.

Thanks for your help.

Ryan

comment:11 Changed 8 years ago by willie

  • Keywords ancillary added
  • Resolution set to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.