Opened 8 years ago

Closed 8 years ago

#830 closed help (fixed)

problem with reconfiguration

Reported by: anmcr Owned by: willie
Component: UM Model Keywords: reconfiguration
Cc: Platform:
UM Version: 7.6

Description

Hi Willie,

I'm getting an error while reconfiguring the startdump of 'No interpolation required, but input and output data fields are different sizes'. This is job xhagf. Myself and Andy Elvidge have both had this error before and your suggestion was to add the RECONA_add_srce_4.txt handedit. I have done this but the error is still there.

This job has 85 vertical levels. Previously when I ran it with 70 vertical levels (UK4_L70 vertlevs) it worked fine (xhagc).

So I really don't know what the problem is. these jobs are all copied from Andy Elvidge and you will see an 'intermediate' step of reconfiguring on Monsoon is required.

Thanks for any help,

Andrew

Change History (8)

comment:1 Changed 8 years ago by willie

  • Owner changed from um_support to willie
  • Status changed from new to accepted

Hi Andrew,

The hand edit is a red herring. It is complaining about the start dump ozone field: in job xhagc it is full field 388x460x35; in xhagf it is 1x460x85. So I think you should select 'zonal' ozone or re-create your start dump.

Regards,

Willie

comment:2 Changed 8 years ago by anmcr

Hi Willie,

I am trying to select 'zonal' ozone. I changed the panel in atmosphere / scientific parameters and sections / section by section choices / ozone from 'impose prescribed 3D field' to 'impose prescribed 2D field'. I then recompiled the reconfiguration executable. However, I'm still getting the same error.

Andrew

comment:3 Changed 8 years ago by willie

Hi Andrew,

The problem is that your ozone ancillary file is full field, but the start dump contains zonal ozone. I was going to recommend ticking the zonal button on the Ancillary > Climatology > Ozone page until I realised this was referring to the ancillary. SO I think you have two choices: either re-create the start dump with full field ozone or create an ancillary file with zonal ozone. In any event, the start dump and ancillary should agree on full/zonal.

Regards,

Willie

comment:4 Changed 8 years ago by anmcr

Hi Willie,

I got around this by switching off the ozone ancillary, so that the ozone field comes from the origional metoffice startdump. So it appears to reconfigure now. However, when the run begins I get an error saying 'Error reading field from dump' or more specifically

Attempting to read field (model, section, item) 1, 0, 60
UM_READDUMP - Error while attempting to read field 463 of 1692 from unit 21

so it seems there is still a problem.

I have never encountered this problem before. Can I repeat that I got this model working with the L70 (upto 40km) dataset, and am (simply) trying here to run it with the L85 dataset. Maybe this is not as straightforward as I imagined.

Thanks,

Andrew

comment:5 Changed 8 years ago by willie

Hi Andrew,

It is failing to read the ozone field in the start dump. The L70 data set (which I assume is xhagc) uses a start dump with full field ozone, in agreement with the ancillary file. I note that you have reconfiguration switched off. It may be better to switch reconfiguration on (saving your start dump in another directory first!). It would also be a good idea to switch on "flush buffer if run fails", in Scientific Section > section13, DIAG_PRN.

Regards

Willie

comment:6 Changed 8 years ago by anmcr

Hi Willie,

I'm pretty confused by this. All I want is to get the job running.

The startdump I'm using to initiate the 4 km L85 run has an ozone field of dimensions 1x769x70.

The procedure I take is to first reconfigure this startdump on Monsoon (xhage). I have switched off any ozone reconfiguration here as I don't have a L85 ancillary. The reconfigured startdump has a ozone field of dimensions 1x460x85, ie zonally averaged but extended to L85 levels.

Then what I done was to run the model (xhagf), and made sure that the field atmosphere / ancillary and input data files / climatologies and potential climatologies / ozone was set to 'ozone is held as zonal average values'. And also that the field atmosphere / scientific parameters and sections / section by section choices / ozone was set to 'Impose prescribed 2D field'.

I don't see anything here which is inconsistent?

Andrew

comment:7 Changed 8 years ago by anmcr

Hi Willie,

It's running now so please close this ticket. I went through the job and made sure I was doing what I suggested in the previous entry.

Thanks,

Andrew

comment:8 Changed 8 years ago by willie

  • Resolution set to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.