Opened 8 years ago

Closed 8 years ago

#831 closed help (fixed)

problem with xancil

Reported by: anmcr Owned by: jeff
Component: UM Tools Keywords:
Cc: Platform:
UM Version: <select version>

Description

Hi Jeff,

When I run xancil to make my own sea-ice and sst ancillaries I now get an error such as 'Warning: variable iceconc has different variable type to its attribute'.

For example, if I run /home/n02/n02/anmcr/work/UMAncil/DAILY/20040725/new_Antarctica12km.job I get this error. This job worked fine before as you can see by the files it produced new_Antarctica12km.ice and new_Antarctica12km.sst from the corresponding netcdf files.

I would appreciate any help,

Thanks,

Andrew

Change History (3)

comment:1 Changed 8 years ago by jeff

  • Owner changed from um_support to jeff
  • Status changed from new to accepted

Hi Andrew

This is not an error message but a warning message, so may not be the cause of any problems you are having. In your case the message means that the iceconc (and field92) field is of type double (i.e. 64 bit) but the missing data value (both missing_value and _Fillvalue) is of type real (i.e. 32 bit). As the missing data value needs to be equated to missing values in the variable this can cause errors in determining whether data is missing or not. Usually this won't be a problem but it has caught me out in the past, so it is best not to do this.

Jeff.

comment:2 Changed 8 years ago by anmcr

Thanks Jeff. Problem solved. Andrew

comment:3 Changed 8 years ago by jeff

  • Resolution set to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.