Opened 12 years ago

Closed 11 years ago

#84 closed help (fixed)

Wrong no of atmos prognostic fields

Reported by: hanneke Owned by: lois
Component: UM Model Keywords:
Cc: Platform:
UM Version:

Description

Hello,

I have a global run (to get LBC files for my LAM runs) that crashes with this error:

OPEN: File /hpcx/devt/n02/n02-ncas/hanneke/globaldumps/sep02/2002090306.T+3 to be Opened on Unit 21 Exists

Mismatch in no of prognostic fields.
No of prog fields in Atmos dump 750
No of prog fields expected 776

Run RECONFIGURATION to get correct no of prognostic fields in atmos dump
or
Check/Reset? experiment in User Interface

Failure in call to INITDUMP
*
UM ERROR (Model aborting) :
Routine generating error: INITIAL
Error code: 102
Error message:

INITDUMP: Wrong no of atmos prognostic fields

*

I had a look through old tickets and did find one with a similar problem: http://ncas-cms.nerc.ac.uk/trac/UMHelpdesk/ticket/74

I am using a global dump however, that I got from Chang. It does have less variables than other global dumps I have used. I have done a reconfiguration on this global dump to get a start dump for the LAM run and this worked fine. But how can I get the boundary conditions from this start dump?

Thanks for your help!
Hanneke

Change History (5)

comment:1 Changed 12 years ago by lois

  • Owner changed from um_support to lois
  • Status changed from new to assigned

Sorry for the delay Hanneke, I will have look at the problem shortly.
Lois

comment:2 Changed 12 years ago by lois

Hello Hanneke,
Let me just check what you are tryng to do.
You are running a global job with one of Chang's start files, which gives you the message 'Mismatch in no of prognostic fields' and you saying reconfiguration cures this problem.
So why can't you use this reconfigured global start dump to re-run your global job to get the LBCs for your LAM?

Thanks
Lois

comment:3 Changed 12 years ago by hanneke

Hello Lois,

No, I reconfigured the global start dump to a LAM start dump. I will try to reconfigure it to a global start dump instead, but do you know why my global dump does not work straight away?

Cheers,
Hanneke

comment:4 Changed 12 years ago by hanneke

Hello,

I am still struggling with this run. I have tried to do a reconfiguration only run to get a newly reconfigured global start dump. It gives me this error message:

*
ERROR!!! in reconfiguration in routine Rcf_Set_Data_Source
Error Code:- 30
Error Message:- Stashcode 216 : Required field is not in input dump!
Error generated from processor 0
*

It does create a .astart file but all fields have zeros.
I have tried the same run on a different global start dump and that does work, so there seems to be something wrong with this start dump (/hpcx/devt/n02/n02-ncas/hanneke/globaldumps/sep02/2002090306.T+3). Can someone look into this?

Thanks!
Hanneke

comment:5 Changed 11 years ago by lois

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.