Opened 8 years ago

Closed 8 years ago

#845 closed help (fixed)

Internal compiler error: upgrade phase 2b- phase 3

Reported by: dan2012 Owned by: jeff
Component: UM Model Keywords:
Cc: Platform:
UM Version: 7.3

Description

Dear Sir/Madam?,

After following the instructions to upgrade from phase 2b to phase 3 and submitting the job (ID: xhdta) I am receiving the following compiler error:

ftn-7991 crayftn: INTERNAL ASAD_CHEMICAL_DIAGNOSTICS, File = /home/n02/n02/dan2012/um/xhdta/ummodel/ppsrc/UM/atmosphere/UKCA/asad_chem_flux_diags.f90, Line = 8346

INTERNAL COMPILER ERROR: "unexpected type in TYPE_DEREF" (v_expr_obj.c 87117, line 751)

fcm_internal compile failed (256)

Any help on identifying the source of this error would be greatly appreciated.

Many thanks in advance for your time
Best,
Dan

Change History (7)

comment:1 Changed 8 years ago by grenville

  • Owner changed from um_support to grenville
  • Status changed from new to assigned

Dan

Please give us permission to read files in your home space.

chmod -R g+rx /home/n02/n02/dan2012

and for future help it'll be convenient to have permission to read files in your work space too

chmod -R g+rx /work/n02/n02/dan2012

You can restrict read permissions to individual directories of course if you wish.

Grenville

comment:2 Changed 8 years ago by dan2012

Dear Grenville,

Thanks, permissions changed accordingly,

Best,
Dan

comment:3 Changed 8 years ago by grenville

  • Owner changed from grenville to jeff

comment:4 Changed 8 years ago by jeff

Hi Dan

The problem is a internal Cray compiler error, which will need to be fixed by Cray. But if you reduce the optimisation level to -O1 then it will compile fine. I have made a compile override file which I think will do this but it is untested so get back to me if it doesn't work. The file is

/home/jeff/umui_jobs/overrides/hector_fix_asad_chem_flux_diags_7.3

It needs to go in umui panel

Compilation and Modifications → UM User Override Files → User file overrides

Jeff.

comment:5 Changed 8 years ago by dan2012

Hi Jeff,

Thanks so much, it now compiles sucessfully.

Cheers,
Dan

comment:6 Changed 8 years ago by luke

Hi Dan,

Can I also point you to http://www.ukca.ac.uk/wiki/index.php/Bugfixes page. This gives information for fixes to the release jobs and branches. If any other corrections are need the information will be posted here.

Thanks,
Luke

comment:7 Changed 8 years ago by jeff

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.