Opened 8 years ago

Closed 8 years ago

#847 closed help (fixed)

fcm gui does not work

Reported by: frec Owned by: ros
Component: FCM Keywords: fcm gui
Cc: Platform: PUMA
UM Version:

Description (last modified by ros)

Hello,

I'm trying to patch a branch across but when I type "fcm gui" I get an error message:

puma:/home/frec$ fcm gui

X11 connection rejected because of wrong authentication.
couldn't connect to display "localhost:19.0" at /usr/lib/perl5/vendor_perl/5.10.0/x86_64-linux-thread-multi/Tk/MainWindow.pm line 55.
MainWindow->new() at /home/um/fcm/bin/fcm_gui line 267

I did this in March and it worked fine and I haven't changed anything since then.

Thanks,
Emilie

Attachments (3)

sshX.txt (3.6 KB) - added by frec 8 years ago.
sshY.txt (3.5 KB) - added by frec 8 years ago.
moressh.txt (1.7 KB) - added by frec 8 years ago.

Download all attachments as: .zip

Change History (12)

comment:1 Changed 8 years ago by ros

  • Description modified (diff)
  • Status changed from new to accepted
  • UM Version <select version> deleted

Hi Emilie,

I think this is because the windows forwarding isn't working.
When you ssh'd to puma did you use "ssh -X ….."?

Cheers,
Ros.

comment:2 Changed 8 years ago by frec

Hi Ros,

Thanks, looks like it could be that. I usually use "ssh -Y …". I've just tried logging in again and now it comes up with "Warning: No xauth data; using fake authentication data for X11 forwarding." when I try "ssh -Y ecarte@…" or "ssh -X …". It also won't let me use nedit now on MONSooN. Is there anything I can do to check why the windows forwarding isn't working?

Thanks,
Emilie

comment:3 Changed 8 years ago by ros

Hi Emilie,

I've spoken to our IT systems guy and he has asked if you could try a fresh login to puma with -X and also one with -Y. Do you still get the problem when typing xterm? If you go directly to monsoon from your local computer can you get an xterm to open?

Cheers,
Ros.

Changed 8 years ago by frec

Changed 8 years ago by frec

comment:4 Changed 8 years ago by frec

Hi Ros,

It responds exactly the same whether I use X or Y, see attached.

Thanks,
Emilie

comment:5 Changed 8 years ago by frec

Also, I don't seem to have a problem with this when I log on to other servers or the MO IBM, it just seems to be MONSooN and PUMA.

comment:6 Changed 8 years ago by ros

Hi Emilie,

Speaking to a Met Office colleague they say you must use "ssh -Y" apparently "ssh -X" doesn't work from the Met Office. He's logged in fine so that implies it is definitely your setup or your computer. Could you try moving the .Xauthority file on exxvmmonsoonssh (or if that fails all of them!) elsewhere. This can sometimes help. Also check that you do not have $DISPLAY exported in your .profile, .bashrc or .kshrc.

Regards,
Ros.

comment:7 Changed 8 years ago by frec

Hi Ros,

I don't have the DISPLAY exported anywhere and I've tried moving the .Xauthority file (everywhere I can see it) but this hasn't helped. I've tried it on another computer too and the same thing happens so it must be something in my set up, but I don't think I've done anything to it since the last time I used MONSooN or PUMA.

Thanks,
Emilie

Changed 8 years ago by frec

comment:8 Changed 8 years ago by ros

  • Platform set to PUMA

This problem was caused by Emilie logging into PUMA via MONSooN rather than logging directly from the Met Office onto PUMA. Somehow going via MONSooN screwed up her environment.

comment:9 Changed 8 years ago by ros

  • Resolution set to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.