Opened 12 years ago

Closed 12 years ago

#85 closed help (fixed)

Reconfiguration fails at call to control

Reported by: umdoc Owned by: lois
Component: UM Model Keywords:
Cc: Platform:
UM Version:

Description

Dear UMSUPPORT,
I have for some time been trying to get an experiment to run on the hpcx. I currently have the results of two attempts on the hpcx.
The runs are in ~richie/umui_runs/
and are named xcocd and xcpxc
the output (leave files) have been copied to this directory too.

xcpxc tries to read in a binary file with ecmwf data in it by convincing the UM it is a grib file.
I realise this is somewhat unusual but it worked on newton. The mod for this bit is
um_mods/vn4.5/recon_grads.mod

xcocd uses a start dump from a run on newton.

Both runs are at 432 * 325 horizontally and use VN4.5. With liberal use of print statements I have found that the problem occurs when
moving from scontrol to control (in the case xcpxc this is after the grib/binary has been read.)

I am hoping that there is a very obvious error I have made moving from newton to hpcx and if you could help to find it
I would be very grateful.
Cheers,
Richard


Richard Ellis.
Centre for Ecology and Hydrology,
Room 63, Mclean Building,
Crowmarsh Gifford, Wallingford,
Oxfordshire, OX10 8BB, UK.
Tel: 01491 692571

Change History (2)

comment:1 Changed 12 years ago by lois

  • Owner changed from um_support to lois
  • Status changed from new to assigned

We are looking at the problem Richard.
Lois

comment:2 Changed 12 years ago by lois

  • Resolution set to fixed
  • Status changed from assigned to closed

This problem was caused by not setting the STACK size for the job running on HPCx. On CASAR this was not necessary but on HPCx the default stack size in so small (20Mbytes) that it should always be set for HPCx. The UMUI on PUMA has been changed from the defualt PUM version to enable the STACK size to be set easily.

Lois

Note: See TracTickets for help on using tickets.