Opened 8 years ago

Closed 7 years ago

#852 closed help (fixed)

UM Executable problem

Reported by: cplanche Owned by: um_support
Component: UM Model Keywords: LAM
Cc: Platform: <select platform>
UM Version: 7.7

Description

Hi,

I am running a 1km LAM on MONSooN (xhgjh job) and I am getting an error:

 Signal received: SIGFPE - Floating-point exception
  Signal received: SIGFPE - Floating-point exception
    Signal generated for floating-point exception:
      FP overflow
  Instruction that generated the exception:
    fdiv fr19,fr04,fr05
  Traceback:
    Signal generated for floating-point exception:
      FP overflow
  Instruction that generated the exception:
    fdiv fr19,fr04,fr05
  Traceback:
    Offset 0x000133c4 in procedure __conv_diag_mod_NMOD_conv_diag_, near line 851 in file /home/pfield/xgxbh/ummodel/ppsrc/UM/atmosphere/convection/conv_diag_4a.f90
    Offset 0x000133c4 in procedure __conv_diag_mod_NMOD_conv_diag_, near line 851 in file /home/pfield/xgxbh/ummodel/ppsrc/UM/atmosphere/convection/conv_diag_4a.f90
    Offset 0x000052b8 in procedure atmos_physics2_, near line 3691 in file /home/pfield/xgxbh/ummodel/ppsrc/UM/control/top_level/atmos_physics2.f90
    Offset 0x000052b8 in procedure atmos_physics2_, near line 3691 in file /home/pfield/xgxbh/ummodel/ppsrc/UM/control/top_level/atmos_physics2.f90
    Offset 0x0001cbd0 in procedure atm_step_, near line 12185 in file /home/pfield/xgxbh/ummodel/ppsrc/UM/control/top_level/atm_step.f90
    Offset 0x0001cbd0 in procedure atm_step_, near line 12185 in file /home/pfield/xgxbh/ummodel/ppsrc/UM/control/top_level/atm_step.f90
    Offset 0x0008792c in procedure u_model_, near line 4112 in file /home/pfield/xgxbh/ummodel/ppsrc/UM/control/top_level/u_model.f90
    Offset 0x0008792c in procedure u_model_, near line 4112 in file /home/pfield/xgxbh/ummodel/ppsrc/UM/control/top_level/u_model.f90
    Offset 0x00002340 in procedure um_shell_, near line 3060 in file /home/pfield/xgxbh/ummodel/ppsrc/UM/control/top_level/um_shell.f90
    Offset 0x00002340 in procedure um_shell_, near line 3060 in file /home/pfield/xgxbh/ummodel/ppsrc/UM/control/top_level/um_shell.f90
    Offset 0x00000090 in procedure flumemain, near line 48 in file /home/pfield/xgxbh/ummodel/ppsrc/UM/control/top_level/flumeMain.f90
    --- End of call chain ---
    Offset 0x00000090 in procedure flumemain, near line 48 in file /home/pfield/xgxbh/ummodel/ppsrc/UM/control/top_level/flumeMain.f90
    --- End of call chain ---


I can't see any more details about the error in the output.
Many thanks for your help.

Cheers,
Celine

Change History (4)

comment:1 Changed 8 years ago by jeff

Hi Celine

Looking at line 851 in conv_diag_4a.f90

       Rhostar = pstar(i,j) / ( R*tstar(i,j) )

and the error message (Floating point overflow) suggests that either R or tstar have very small values and is causing the model to crash. If you look at the surface temperature field in your start dump it does indeed have very small non-physical values over sea points, so this looks like the cause of the model crash. As to how this happened and what to do to fix it, I'm not too sure. The person who is more familiar with limited area nested models is at a conference this week but might have a better idea what to do next if you can't figure it out.

Jeff.

comment:2 follow-up: Changed 8 years ago by willie

Hi Celine,

There are some STASH errors that should be corrected in this job. I have been unable to locate the start dump, but I would cumf the start dump with itself just to check for invalid input data: look in the summary output file and it should say that there are no difference.

Your set up method is not one I've seen before. Is the the result of running an automatic tool?

Regards,
Willie

comment:3 in reply to: ↑ 2 Changed 8 years ago by cplanche

Hi Willie,

I fixed the STASH errors and the mistake is still present. The problem certainly comes from the start dump. I need to check it.
The result of running is effectively obtain with an automatic tool provided by some Met Office people. I will try to contact them to know if they have already seen similar problem.
Many thanks.

Regards,
Celine

comment:4 Changed 7 years ago by willie

  • Platform set to <select platform>
  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.