Opened 8 years ago

Closed 8 years ago

#870 closed help (fixed)

Crash during compilation of an idealised job

Reported by: cplanche Owned by: um_support
Component: UM Model Keywords: Monsoon, Idealised job
Cc: Platform:
UM Version: 8.0

Description

Hi,

I am doing the setup of an idealised case on Monsoon.
My job (xhixb) uses a namelist which includes a bubble perturbation. In a first step, I would like to run the job with no moisture and all physics. When it will works I then will switch on the bits of physics I need.

However, the job crashes during the compilation. The *.comp.leave file just indicates :

→Generate Fortran interface: 0 second
→Make: start
gmake: * No rule to make target tilepts.done', needed by ses2_rad0.done'. Stop.
gmake:
* Waiting for unfinished jobs….
gmake -f /projects/asci/cplanc/xhixb/umatmos/Makefile -j 6 -s all failed (2) at /projects/um1/fcm/bin/../lib/Fcm/Build.pm line 598
Build failed on Mon Jul 2 09:23:41 2012.
→Make: 2 seconds
→TOTAL: 25 seconds
UMATMOS build failed

I don't really know what is the problem.
Many thanks.

Celine

Change History (18)

comment:1 Changed 8 years ago by ros

Hi Celine,

Errors of this nature are usually caused by dodgey combinations of preprocessor keys (DEFs). See the FAQ

http://puma.nerc.ac.uk/trac/UM/wiki/FrequentlyAskedQuestions#gmake-no-rule-to-make-target

If you look in preprocessed file
/projects/asci/cplanc/xhixb/umatmos/src/UM/atmosphere/vegetation/tilepts.f90 you'll see there is no code in the file. It has all been switched off by options in the UMUI, however it is needed by another file/section.

Looking at the raw code before code sections are switched on or off as appropriate, we can see at the top of the file that this code is controlled by section 19 (Vegetation Distribution).
/projects/asci/cplanc/xhixb/baserepos/UMATMOS/src/UM/atmosphere/vegetation/tilepts.F90

So I would suggest that turning on Section 19 version 1A or 2A in the UMUI panel Atmosphere →Sci Params & sections → Section by Section Choices → Section 19: Vegetation Distribution would solve this problem. If, however, you don't wish to run with vegetation distribution then further investigation will be required to figure out what other switches need to be turned off.

Hope that helps.

Regards,
Ros.

comment:2 Changed 8 years ago by cplanche

Hi Ros,

In fact, I would like to run the job without the surface processes. So when I switch off the surface processes (Atmosphere →Sci Params & sections → Section by Section Choices → Section 3) a warning message appears explaining that I also have to switch off the vegetation distribution and the hydrology in the UMUI.
It seems that the job still considers surface processes?
Many thanks.

Regards,
Celine

comment:3 follow-up: Changed 8 years ago by grenville

Celine

The settings you have in Atmosphere→Scientific Paramet..→Model Testing and Running.. indicate that you have chosen to run with no physics - this setting should override whatever you have chosen in Scientific sections and parameters, so switching on vegetaion to avoid the compilation problem won't actually invoke the vegetation scheme. You will need to be careful with physics options when you do run with physics.

Grenville

comment:4 in reply to: ↑ 3 Changed 8 years ago by cplanche

Hi Grenville,

Thanks a lot for your help.

In fact, in a first step I tested to run the idealised job xhixa which was initially coupled with UKCA. I switched off UKCA and it runs.
The job that I would like to test have to consider a periodic LB, no radiative transfer and surface fluxes, no free slip lower boundary, one thermodynamics and dynamics profile and a theta perturbation close to the ground.

Every modification that I tested before crashes (with the initial namelist and profile but no theta perturbation).

So, in a second step I used a new namelist with consider a theta perturbation, a new namelist and no any physics. But it still crashes during the reconfiguration step.

The error message is given in the xhixb000.xhixb.d12186.t162440.rcf.leave
file.

I guess it is due to the ancillary file which cannot be used in this
case (different resolution), but I am not sure?
I tested to switch off the surface processes (Atm → Sci parameters
→Sections by sections → section 3 in UMUI) and the associate
parameters such as the hydrology and vegetation distribution but the job
crashes during the compilation step.

Many thanks.

Regards,
Celine

comment:5 follow-up: Changed 8 years ago by grenville

Celine

I'm not sure what you are trying to do - did you try reconfiguring without including UKCA_srf_1p5km?

Grenville

comment:6 in reply to: ↑ 5 Changed 8 years ago by cplanche

Hi Grenville,

Yes, I would like to delete all surface and UKCA features.

Cheers,
Celine

comment:7 Changed 8 years ago by grenville

Celine

Could you not start from a less complex job - there is a umui standard idealized job (experiment xfqc) which might be a simpler place to begin.

I can get the model to reconfigure OK by switching of aerosols and removing user stash (see xhjsa), but it fails trying to figure out levels for cloud layers.

Grenville

comment:8 Changed 8 years ago by cplanche

Hello Grenville,

I can't use these idealised standard jobs on Monsoon?
Many thanks.

Cheers,
Celine

comment:9 Changed 8 years ago by grenville

Celine

We can make a MONSooN idealised job, but I'm still not sure where you want to go with this - an idealised job that we create will most likely not easily be extended to include UKCA. Are you planning to develop the idealised model to include UKCA?

Grenville

comment:10 Changed 8 years ago by cplanche

Grenville,

In fact, I work with Met Office people who are already setup an idealised job with UKCA. I used this job to start my idealised study, but I don't plan to keep UKCA in my setup.
I would like to study the idealised squall line case for the WMO conference planed at the end of July. The details of this setup is provided by this link:

http://www.rap.ucar.edu/~gthompsn/workshop2012/case2/

In order to study this case, I had to use periodic lateral boundary, no radiative transfert and surface processes, switch on the free slip lower boundary and create a new namelist with a single profile and a bubble theta perturbation close to the ground.

I know that the idealised job that I have is quite complex, but I don't know another one with LBA which can be run on Monsoon.

Many thanks.

Cheers,
Celine

comment:11 Changed 8 years ago by cplanche

Hi Grenville,

As my job on Monsoon is too complicated, I also tested the Schar problem (xhkaa job) on Hector. I will then modified it with the WMO required setup. If I well understand, I need a new namelist, initiate a bubble perturbation, delete the orography, modify the model resolution and domain and add a 3d periodic lateral boundary conditions…
Do I need to modify the start dump, if I use a finer resolution with a larger domain?
And for the lateral bounadry conditions, how I can setup the requested conditions?

However, I had a problem during the submission. When I submitted the job, I had to write my password to connect me on Hector, the extraction then started but it failed just after "NDS_MAIN: Extract ok". Then, the UMUI crashed.
Do you know what is this problem?
Many thanks

Celine

comment:12 Changed 8 years ago by grenville

Celine

It sounds like your ssh setup has got confused. If you can ssh to hector from the puma command line, then the umui should submit properly. I'm assuming that you have previously set up ssh so that you are not required to enter a password each time you attempt a connection to hector. Delete ~cplanche/.ssh/environment.puma, log out of puma and login again. Try ssh'ing to hector (you may need to run ssh-add).

The job that Mohit set up had EW and NS cyclic boundary conditions - this is set in Atmosphere→Model Resolution…→Horizontal - xhkaa has EW cyclic boundary conditions (the NS boundaries are allowed to vary freely in this case).

The start dump is a global aquaplanet start dump - the reconfiguration will regrid this to your chosen domain (I am not sure how the model will behave if you change the resolution radically).

Please see UM documentation paper 33 (Running the Unified Model in Idealised Mode) for detailed information on lateral boundary forcing.

Grenville

comment:13 Changed 8 years ago by cplanche

Hi Grenville,

Thanks for your help.
I had already done this, and I can connect to Hector with the ssh but I can't submit a job.

Cheers,
Celine

comment:14 Changed 8 years ago by ros

Hi Celine,

Can I just confirm that when you ssh on the command line from puma to HECToR that it does NOT ask for your password?

Cheers,
Ros.

comment:15 follow-up: Changed 8 years ago by ros

Hi again,

Just realised why it's not submitting. You need to change the userid in "user info and submit method → general details" to be your HECToR user id. It's currently set to your MONSooN one.

Regards
Ros.

comment:16 in reply to: ↑ 15 Changed 8 years ago by cplanche

Hi Ros,

I am not sure you checked the good job (xhkaa) because I already gave my Hector user-id. At the beginning my problem was with a quite "complex" idealised job that I tried to use on Monsoon but it still doesn't work so I asked a standard idealised job on Monsoon. Apparently, there are no standard idealised job on Monsoon.
So I thought that I can use one on Hector, but I have a submission problem.

When I connect with the ssh on command line it asks me for my password.
I usually work on Monsoon, and at the beginning I can't submit a job on Monsoon because the ssh I created during the UM tutorial on Hector not allowed this.
Do you think it is the same stuff? It was very complicated to create the correct keys for monsoon, so, I don't want to lose it.
I should ask to Met Office people an idealised job available on Monsoon and less complex than the first one.

Many thanks.

Cheers,
Celine

comment:17 Changed 8 years ago by ros

Hi Celine,

Sorry - yes I looked at the wrong job. :-(

If you regenerated your ssh keys on PUMA for MONSooN, then that will be why it's got messed up for HECToR, because now the keys don't match.

With any luck all you will need to do is copy your existing PUMA public key onto HECToR.
See step 2 of the ssh-setup instructions.
http://puma.nerc.ac.uk/trac/UM_TUTORIAL/wiki/Ros/sshAgent

Once you've done that try ssh to hector and hopefully it won't prompt for a password or passphrase.

If it prompts for a passphrase, then you will need to run "ssh-add".

Regards
Ros.

comment:18 Changed 8 years ago by ros

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.