Opened 8 years ago

Closed 8 years ago

#874 closed error (fixed)

Reconfiguring ECMWF dump to N512, 70 levels (vn7.6)

Reported by: a.elvidge Owned by: um_support
Component: UM Model Keywords: reconfiguration, biogenic aerosol
Cc: Platform:
UM Version: 7.6

Description

Hi,

I am attempting to run a vn7.6 job at resolution N512 with 70 levels from an ECMWF dump. I have tried two different methods but have encountered stumbling blocks each time.

Method 1) Used xdkeb to reconfigure the start dump to N320 and 50 levels. This worked, but then I encountered a problem in the re-reconfiguration as part of my vn7.6 global N512 70L job (xfxko). I cannot however find any clear error message in the .rcf.leave file, just:

 gc_abort (Processor  63 ): Job Aborted from Ereport
Application 2365895 exit codes: 9
Application 2365895 exit signals: Killed

I thought it may be because of the transition from low resolution N320 and 50 levels to higher resolution N512 and 70 levels, so…

Method 2)

I constructed my own vn7.6 reconfiguration only job for the ECMWF dump at resolution N512 with 70 levels.

The job is xfxks. I generated ancillaries using the ancil file service. I'm getting the following error:

C I/O Error: failed in BUFFIN8
Return code = 1

I've had this error before but the job has still run ok, but not this time…

gc_abort (Processor  63 ): Job Aborted from Ereport
Application 2367112 exit codes: 9
Application 2367112 exit signals: Killed

Reading advice from previous tickets, it appears that the solution may be to "reduce the optimisation to -O0" by using the override file:

/home/n02/n02/wmcginty/overrides/reduced_opt.ovr

which simply includes this line:

@fort FCOM_OPTIM=-O0

But it seems that vn7.6 requires override files to be located on puma. So I moved that file to puma and listed it as a user file override but get an error in my ext.out file:

ERROR: /home/a.elvidge/overrides/reduced_opt.ovr: LINE 1:
       @fort: label not recognised.

Any help much appreciated!

Thanks, Andy

Change History (3)

comment:1 Changed 8 years ago by willie

  • Keywords reconfiguration, biogenic aerosol added

Hi Andy,

Your job xfxko is failing in reconfiguration because it can't find STASH 351 |CLIM BIOGENIC AEROSOL in the start dump.

To get rid of this you need to go to Scientific sections > Aerosol and select Areo_clim; switch off include biogenic aerosol climatology. Then select Aero ancils and select not used for the biogenic aerosol climatology.

Regards,

Willie

comment:2 Changed 8 years ago by a.elvidge

Hi Willie,

Thanks. I had to switch off all the aerosol climatologies (not just biogenic) on Scientific sections > Aerosol to get it to work.

Thanks, Andy

comment:3 Changed 8 years ago by willie

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.