Opened 8 years ago

Closed 8 years ago

#890 closed help (fixed)

Trouble using custom orography ancillary file (vn7.8)

Reported by: abarrett Owned by: jeff
Component: UM Model Keywords: Xancil, unfiltered orography
Cc: Platform: <select platform>
UM Version: 7.8

Description

Hi,

I have created a custom orography ancillary to use in a UKV model run by:

  1. taking standard OROG ancillary
  2. converting to netCDF in xconv
  3. modifying orography values in MATLAB
  4. using xancil to create new OROG ancil file
  5. reconfiguring coarser resolution start dump to generate UKV start dump

The problem I have comes during the reconfiguration in step 5, where i get the error:

ERROR!!! in reconfiguration in routine Rcf_Ancil_Atmos
Error Code:- 388
Error Message:- REPLANCA: PP HEADERS ON ANCILLARY FILE DO NOT MATCH
Error generated from processor 0

I understand from previous NCAS-CMS tickets (#807) that the error code relates to field 188 (Error Code - 200): Unfiltered orography.

I think part of the problem is that xancil is not able to create the Unfiltered Orography field in the ancillary file (there is no option to include it).
I proceeded to the reconfiguration anyway, without the Unfiltered Orography, and got the above error.

If, in the UMUI, I uncheck the option 'the unfiltered orography to be configured', the reconfiguration works fine, but produces a start dump which does not contain unfiltered orography. When running the model using this start dump it fails, expecting the unfiltered orography to be present.

How do I get around this problem? Is it possible to create an ancillary file which includes the Unfiltered Orography, or is it possible to read it from the standard OROG ancillary file when I choose not to configure it?

The job id is xhglz and my created orography file is on hector at: /work/n02/n02/abarrett/MOGREPSUKV/ANCIL/orog.flatld

Many thanks
Andrew

Change History (7)

comment:1 Changed 8 years ago by willie

Hi Andrew,

Your orography file is twice the size of the standard one, despite having the same fields. Did you use "well formed" and a sector size of 2048 in the general Xancil set up? Also, if you select the "Trans" button in xconv, you will see that your file has "Regular latitude/longitude grid with non-standard polar axis" - this is not appropriate for variable resolution required by the UKV model.

I hope that helps.

Regards,

Willie

comment:2 Changed 8 years ago by annette

  • Owner changed from um_support to annette
  • Status changed from new to assigned

Hi Andrew,

Just a few questions…

Was the unfiltered orography in the original start dump or orography file? Or is it just required because of the changes you are making?

Also can you point me to the job which failed when you reconfigered without unfiltered orography, and the output file?

Thanks,
Annette

comment:3 Changed 8 years ago by abarrett

Willie,

Initially I did not use "well formed", but including this does not change anything significantly as far as I can see (the new file is fractionally larger - 140KB). With reference to the grid, is it currently possible to output a grid suitable for UKV from xancil, I don't see any options?

Annette,

The unfiltered orography exists in both the start dump of my standard UKV run (e.g. /work/n02/n02/abarrett/MOGREPSUKV/DUMPS/20110827/20110827.oper09.start.0900 ) and the default orography ancillary ( /work/n02/n02/hum/ancil/atmos/ukv/orography/dted1/v4/qrparm.orog, called 'Stash Code = 7').

My reconfiguration job is xhglz:
In its current setup the reconfiguration runs, producing the start dump with no unfiltered orography: /work/n02/n02/abarrett/MOGREPSUKV/DUMPS/20110827/20110827.oper09.start.0900.flatld
If I ask it to configure the unfiltered orography, it fails, the .leave file is here: /home/n02/n02/abarrett/um/umui_out/xhglz000.xhglz.d12223.t153251.rcf.leave

Thanks
Andrew

comment:4 Changed 8 years ago by willie

  • Keywords Xancil, unfiltered orography added

Hi Andrew,

It looks like there are two issues with Xancil. It needs to handle the variable resolution grid and it needs to explicitly handle the unfiltered orography. I have spoken to Jeff Cole and it seems that he may be able to upgrade Xancil. This may take about a week.

The unfiltered orography was not present in the PS22 UKV set up, but it is needed in the PS27.

Regards,

Willie

comment:5 Changed 8 years ago by jeff

  • Owner changed from annette to jeff

Hi Andrew

I've updated xancil to support the variable resolution grid and added unfiltered orography. For the moment you should try this version /home/n02/n02/jwc/bin/xancil0.53. The variable resolution grid is switched on in the Grid Configuration panel. You should use xconv1.92 to create the netcdf file and set the netcdf output precision to be 64 bit. Let me know if there are any problems, if everything works ok then I will release this version.

Jeff.

comment:6 Changed 8 years ago by abarrett

Jeff,

Thanks for updating xancil so quickly for me. The new version of xancil seems to work perfectly, creating an orography ancillary that runs with no problems. I'm still looking through the output, but haven't yet noticed any problems.

Thanks for your help, (you can now close this ticket)

Andrew

comment:7 Changed 8 years ago by jeff

  • Platform set to <select platform>
  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.