Opened 7 years ago

Closed 7 years ago

#894 closed help (fixed)

failure to create a branch for the first time

Reported by: challi Owned by: ros
Component: UM Model Keywords:
Cc: Platform:
UM Version: <select version>

Description

I have a patch that I want to create a branch with and but I am having difficulties creating a branch on MONSooN. I tried using the fcm gui with the —password "" option and it failed. I also tried the command line but this also failed. At one point it appeared to have created a branch but when I tried to use the patch it complained that my branch didn't exist.

on the gui, it just complained about the password option and didn't allow me to comment, although said it had created a branch

On the command line, I tried the following command (and also a permutation of this, with the password bit in other places)
fcm bc cs_trap fcm:um@vn7.8 —password ""
(this is what I have used here at the Met Office)
This allowed me to comment and appeared to create a branch (although at vn8.2!!) although the branch didn't exist when I tried the patch.

I'm not sure what to do now!

Change History (3)

comment:1 Changed 7 years ago by ros

Hi Carol,

Your branch looks to have been created ok or are you trying to create another one? (see http://puma.nerc.ac.uk/trac/UM/browser/UM/branches/dev/challi?rev=) You shouldn't need to supply the —password option since you have already successfully written to the repository so your details are cached.

To apply the patch all you should need to do is run:

/path/to/patch/fcm-import-patch svn://puma/UM_svn/UM/branches/dev/challi/vn7.8_cs_trap2

If it's still causing problems let me know the error message it gives.

Cheers,
Ros.

comment:2 Changed 7 years ago by ros

  • Owner changed from um_support to ros
  • Status changed from new to assigned

This ticket is now being closed as there have been no further comments in 4 weeks.

comment:3 Changed 7 years ago by ros

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.