Opened 7 years ago

Closed 7 years ago

#900 closed help (fixed)

failed during compilation step

Reported by: cplanche Owned by: willie
Component: UM Model Keywords: FCM, password
Cc: Platform: MONSooN
UM Version: 8.0

Description

Hi,

My job xhnta failed during the compilation step and I have no idea about the problem. Problem with these routine or the FCM url that I used.
The error message is :

→Generate Fortran interface: 1 second
→Make: start
→Make: 0 second
→TOTAL: 7 seconds
Build command finished on Fri Aug 31 12:52:37 2012.
UMSCRIPTS build is OK
COMP_UMATMOS is true - run build command
ERROR: /projects/asci/cplanc/xhnta/umatmos/cfg/bld.cfg: LINE 460:

tool::fflags::UM::atmosphere::dynamics_advection::eta_vert_weights_e: invalid sub-package in declaration.

ERROR: /projects/asci/cplanc/xhnta/umatmos/cfg/bld.cfg: LINE 476:

tool::fflags::UM::control::top_level::initial: invalid sub-package in declaration.

ERROR: /projects/asci/cplanc/xhnta/umatmos/cfg/bld.cfg: LINE 477:

tool::fflags::UM::control::top_level::st_diag3: invalid sub-package in declaration.

ERROR: /projects/asci/cplanc/xhnta/umatmos/cfg/bld.cfg: LINE 478:

tool::fflags::UM::control::top_level::u_model: invalid sub-package in declaration.

Build failed on Fri Aug 31 12:52:41 2012.
Build command started on Fri Aug 31 12:52:37 2012.
→Parse configuration: start
Config file (bld): /projects/asci/cplanc/xhnta/umatmos/cfg/bld.cfg
Config file (bld): /projects/asci/cplanc/xhnta/baserepos/UMATMOS/cfg/bld.cfg
→Parse configuration: 4 seconds
→TOTAL: 4 seconds
UMATMOS build failed

Many thanks.

Regards,
Celine

Attachments (1)

Capture.PNG (78.4 KB) - added by cplanche 7 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 7 years ago by willie

  • Owner changed from um_support to willie
  • Status changed from new to accepted

Hi Celine,

You appear to have no FCM branches and your working copy isn't a working copy. If you change directory into the working copy and do 'fcm status' it says it isn't a workinhg copy. Is this correct?

Regards,

Willie

comment:2 Changed 7 years ago by cplanche

Hi Willie,

You're right. So If I well understand I have to create a branch and then modify the different necessary routines in this branch.
The problem is that I tried to create a branch and it failed (#113). As it is the first time I tried to create one, I guess I didn't do this correctly.

I would like to create a branch with the UM vn8.2 but not on the UM tutorial repository. What are the main steps because comparing with the UM User tutorial document I don't see where was my mistake?
Many thanks.

Regards,
Celine


Changed 7 years ago by cplanche

comment:3 Changed 7 years ago by willie

  • Keywords FCM, password added; UM, idealised removed

Hi Celine,

You're nearly there but for the password problem:

svn : Can't get username or password

According to the FCM tutorial you get round this by adding

--password ""

in the "other options" field.

So try this.

Regards,

Willie

comment:4 Changed 7 years ago by cplanche

Hi Willie,

Thanks I now create the vn8.0_WMO_squall line branch and the working copy.
I then modified the FCM options in my xhnta run.
Nevertheless, I have still a same problen during the compilation of the idealised setup. Perhaps I didn't modify the FCM UMUI windows correctly. I have no idea about this problem.
The output file is xhnta000.xhnta.d12269.t115331.comp.leave.

Many thanks.

Regards,

Celine

comment:5 Changed 7 years ago by willie

Hi Celine,

Before you go modifying code, it is a good idea to check that the original branch compiles and runs properly. So switch off the working copy and reinstate the branch and do a run. You will need to check the MONSooN Phase 2 wiki for the recent software changes to phase 2 and the FCM Frequently asked questions for common errors.

Regards,

Willie

comment:6 Changed 7 years ago by willie

  • Platform set to MONSooN
  • Resolution set to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.