Opened 7 years ago

Closed 7 years ago

#903 closed help (fixed)

Issue on setting Up ssh-agent on PUMA

Reported by: dh023729 Owned by: ros
Component: PUMA Keywords: ssh-agent
Cc: Platform:
UM Version: 6.6.3

Description

Hello,

Currently, I'm re-running the HadGEM2-ES from PUMA to HECToR.

I did setup the ssh-agent on PUMA when last time I ran it according to the UM FCM tutorail on the NCAS CMS website: http://puma.nerc.ac.uk/trac/UM_TUTORIAL/wiki/Ros/sshAgent. And it worked by that time, but not anymore when I try it this time. The symptom is that the UMUI stops responding when I click on the Submit button.

So, I reset the ssh-agent again according to the above mentioned webpage. It works fine when I generated the pair of authentication keys, put the pubilc key on the HECToR. However, the ssh-agent cannot be started automatically even though I copied and executable the 'setup' file under the directory '~/.ssh/'.

Everytime, when I typied in 'ssh-add', there was an error information as:
'Could not open a connection to your authentication agent.'

I googled it, and found a way to start the ssh-agent manually by typing in:
'exec ssh-agent bash'

It solves my problem as now I can add RSA identity to the authentication agent, and can submit the job to HECToR. But, I'm still not sure this is the correct way to do it. Any suggestion?

Thanks very much,
Liang

Change History (3)

comment:1 Changed 7 years ago by ros

  • Component changed from FCM Tutorial to PUMA
  • Keywords ssh-agent added
  • Owner changed from um_support to ros
  • Status changed from new to accepted

Hi Liang,

If you get this problem again, it's because your ssh-agent has stopped running for some reason and is unable to restart automatically. Try removing the file /home/dh023729/.ssh/environment.puma on PUMA and then log out and log back in again. You will hopefully then see a message something along the lines of "re-initialising ssh-agent", you should then be able to run ssh-add successfully.

Regards,
Ros.

comment:2 Changed 7 years ago by dh023729

Hi Ros,

The problem is solved:)

Thank you very much,
Liang

comment:3 Changed 7 years ago by ros

  • Resolution set to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.