Opened 8 years ago

Closed 8 years ago

#922 closed help (fixed)

problem with MAKEBC

Reported by: anmcr Owned by: willie
Component: UM Model Keywords: memory, domain size
Cc: Platform:
UM Version: 7.6

Description

Hi again Willie,

I am afraid I am still having a problem with MAKEBC.

I had got the makebc script to to create 3h of LBCs. But when I apply it to create longer LBCs it fails with error given below. As you can see the script name is makebc_xhawl which is in the directory /work/n02/n02/anmcr/makebc/. In this script I am trying to read in 21 input files. I tried to read a different section of the input data [1400 (F22) to 2400 (F42)] but the error repeated. I actually need to eventually read in ~150 input files to create LBCs spanning 3 days for a 1.5km run.

Any help would be appreciated.

Thanks,

Andrew

anmcr@hector-xe6-1:~/work/makebc> ./makebc_xhawl
set up the namelist
set up the input files
set up the output files (automatic overwrite enabled)
/work/n02/n02/hum/vn7.6/cce/utils/makebc: line 249: 10086: Killed
Problem with MAKEBC program
MAKEBC output in: /work/n02/n02/anmcr/tmp/tmp.hector-xe6-1.17393/makebc_out.anmcr.10063
anmcr@hector-xe6-1:~/work/makebc>

Change History (11)

comment:1 Changed 8 years ago by willie

  • Keywords memory, domain size added
  • Owner changed from um_support to willie
  • Status changed from new to accepted

Hi Andrew,

It was running out of memory during the run - I was getting lib-4205 unable to request more memory space". I added

ulimit -M unlimited

to the makebc script and it worked. The 21 dumps were processed in about 20 minutes on the serial queue. You'll need to submit a serial batch job requiring at least 150 minutes - see my setup up at /work/n02/n02/wmcginty/makebc.

Regards,

Willie

comment:2 Changed 8 years ago by anmcr

Hi Willie,

Can you please change the permissions to your 'makebc' directory.

Thanks very much for your help.

Andrew

comment:3 Changed 8 years ago by willie

Try now Andrew

comment:4 Changed 8 years ago by anmcr

Still getting permission denied!

anmcr@hector-xe6-7:/home/n02/n02/wmcginty/work> cd makebc
-bash: cd: makebc: Permission denied

comment:5 Changed 8 years ago by willie

Sorry! Try again please.

comment:6 Changed 8 years ago by anmcr

Hi Willie,

Got access now.

Do I submit to the queue by 'qsub makebc_xhawl'?

Thanks,

Andrew

comment:7 Changed 8 years ago by anmcr

Hi Willie,

Ive got it running - hopefully I should be able to handle it for me.

Thanks again.

Andrew

comment:8 Changed 8 years ago by anmcr

Hi again Willie,

I'm afraid that the MAKEBC run failed while generating timestep #90 (out of ~140). I've copied the error message below.

The output file is /home/n02/n02/anmcr/work/makebc/makebc_out.anmcr.9748

The script name was /home/n02/n02/anmcr/work/makebc/makebc_xhawl_serial_69h

The script name was /home/n02/n02/anmcr/work/makebc/namelist_xhawl_69h

Andrew

The error message is

Processing dump no 91

OPEN: File /work/n02/n02/anmcr/xhawl/xhawla_pi4530 to be Opened on Unit 30 Exists

this is a FieldsFile?

u_field_intfa set to 561750


Model Grid/Levels? in this dump.
row_length = 750
rows = 750
n_rows = 749
model_levels = 70
wet_levels = 70
tr_levels = 1
p_field = 562500
u_field = 561750

No murk lbcs
No pc2 lbcs
No tracer LBCs requested in this run
No UKCA tracer LBCs requested in this run


Dump No 91 : CaLLing IN_INTF.
nftout from intf_unit 140


Dump No 91 : CALLing GEN_INTF.

Gen_Intf: Timestep 90 : Generate Atmos LBCs for Area 1

SETPOS: Unit 140 to Word Address -1716238336 Failed with Error Code -1
anmcr@hector-xe6-7:~/work/makebc>

comment:9 Changed 8 years ago by anmcr

Hi Willie,

The problem is that I have run out of disk space.

I'II delete what I can and re-run.

Andrew

comment:10 Changed 8 years ago by anmcr

hi Willie,

I've made the LBCS and the run is progressing fine. I was trying to do to many things at once. So am doing one high-res run at a time and then deleting anything not needed.

Thank you very much for your help with this.

Andrew

comment:11 Changed 8 years ago by willie

  • Resolution set to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.