Opened 7 years ago

Closed 7 years ago

#960 closed help (fixed)

Compile error submitting UKCA job to HECToR (looks like a general UM error)

Reported by: gmann Owned by: um_support
Component: UM Model Keywords: ukca
Cc: mdalvi, cce_cj Platform: HECToR
UM Version: 7.3

Description

I have trying to port across to HECToR a HadGEM3-A UKCA job that has been running fine on MONSOON.

I solved a few initial minor problems porting the job across but now I'm getting an error

The job is xhwrc — the compile failure is in atmos_physics2 — I have pasted in the full error message below.

See that the compiler is complaining that there are two variables "transalen" and "nftaswap" that are used before they are defined.

I guess this may have been the case on MONSOON, but maybe the
compiler is less fussy there?

Anyway it sounds like it could a bug — I guess someone has
likely encountered this already as it is an FCM branch
that started from HadGEM3-A-r2.0 that Mohit has extended
to include UKCA.

It looks like the bug may have been in that base r2.0 of HG3-A?

Thanks for any help you can give.

Cheers
Graham

—-

# Time taken: 164 s⇒ ftn -o atmos_physics2.o -I/work/n02/n02/gmann/um/xhwrc/ummodel/inc -I/work/n02/n02/gmann/um/xhwrc/umbase/inc -e m -h noomp -s real64 -s integer64 -hflex_mp=intolerant -I /work/n02/n02/hum/gcom/cce/gcom3.8/hector_cce_mpp/inc -c /work/n02/n02/gmann/um/xhwrc/ummodel/ppsrc/UM/control/top_level/atmos_physics2.f90
mv atmos_physics2.o /work/n02/n02/gmann/um/xhwrc/ummodel/obj

TRANS_LEN=TRANSALEN

ftn-7212 crayftn: WARNING INITIAL, File = /work/n02/n02/gmann/um/xhwrc/ummodel/ppsrc/UM/control/top_level/initial.f90, Line = 7494

Variable "transalen" is used before it is defined.

NFTSWAP =NFTASWAP

ftn-7212 crayftn: WARNING INITIAL, File = /work/n02/n02/gmann/um/xhwrc/ummodel/ppsrc/UM/control/top_level/initial.f90, Line = 7495

Variable "nftaswap" is used before it is defined.

Change History (8)

comment:1 Changed 7 years ago by grenville

Graham

We see this warning often but it doesn't result in an unsuccessful build. If your build is failing, there must be some other problem.

Grenville

comment:2 Changed 7 years ago by gmann

Hi Grenville,

Thanks for that.

Sorry — just looked again and I realise that wasn't causing the compilation to fail….

It looks like there are some more serious errors in readlsta — see the
errors below — do you have any suggestion here?

Perhaps I am missing a hand-edit needed for HECToR?

Thanks for your help,

Cheers
Graham

LOGICAL
l_subsample

ftn-1424 crayftn: ERROR READLSTA, File = /work/n02/n02/gmann/um/xhwrc/ummodel/ppsrc/UM/control/top_level/readlsta.f90, Line = 4693, Column = 18

A type must be declared for "L_SUBSAMPLE" before it is referenced, initialized or declared a constant because of IMPLICIT NONE.

LOGICAL
l_geostationary

ftn-1424 crayftn: ERROR READLSTA, File = /work/n02/n02/gmann/um/xhwrc/ummodel/ppsrc/UM/control/top_level/readlsta.f90, Line = 4695, Column = 18

A type must be declared for "L_GEOSTATIONARY" before it is referenced, initialized or declared a constant because of IMPLICIT NONE.

CHARACTER (LEN=80)
sat_desc

ftn-1424 crayftn: ERROR READLSTA, File = /work/n02/n02/gmann/um/xhwrc/ummodel/ppsrc/UM/control/top_level/readlsta.f90, Line = 4697, Column = 31

A type must be declared for "SAT_DESC" before it is referenced, initialized or declared a constant because of IMPLICIT NONE.

REAL
max_view_lon

ftn-1424 crayftn: ERROR READLSTA, File = /work/n02/n02/gmann/um/xhwrc/ummodel/ppsrc/UM/control/top_level/readlsta.f90, Line = 4708, Column = 15

A type must be declared for "MAX_VIEW_LON" before it is referenced, initialized or declared a constant because of IMPLICIT NONE.

REAL
min_view_lon

ftn-1424 crayftn: ERROR READLSTA, File = /work/n02/n02/gmann/um/xhwrc/ummodel/ppsrc/UM/control/top_level/readlsta.f90, Line = 4710, Column = 15

A type must be declared for "MIN_VIEW_LON" before it is referenced, initialized or declared a constant because of IMPLICIT NONE.

REAL
max_view_lat

ftn-1424 crayftn: ERROR READLSTA, File = /work/n02/n02/gmann/um/xhwrc/ummodel/ppsrc/UM/control/top_level/readlsta.f90, Line = 4712, Column = 15

A type must be declared for "MAX_VIEW_LAT" before it is referenced, initialized or declared a constant because of IMPLICIT NONE.

REAL
min_view_lat

ftn-1424 crayftn: ERROR READLSTA, File = /work/n02/n02/gmann/um/xhwrc/ummodel/ppsrc/UM/control/top_level/readlsta.f90, Line = 4714, Column = 15

A type must be declared for "MIN_VIEW_LAT" before it is referenced, initialized or declared a constant because of IMPLICIT NONE.

L_SUBSAMPLE=SW_CONTROL(J)%L_SUBSAMPLE


ftn-356 crayftn: ERROR READLSTA, File = /work/n02/n02/gmann/um/xhwrc/ummodel/ppsrc/UM/control/top_level/readlsta.f90, Line = 5408, Column = 22

Assignment of a LOGICAL expression to a INTEGER variable is not allowed.

L_GEOSTATIONARY=SW_CONTROL(J)%L_GEOSTATIONARY


ftn-356 crayftn: ERROR READLSTA, File = /work/n02/n02/gmann/um/xhwrc/ummodel/ppsrc/UM/control/top_level/readlsta.f90, Line = 5409, Column = 26

Assignment of a LOGICAL expression to a INTEGER variable is not allowed.

SAT_DESC=SW_CONTROL(J)%SAT_DESC


ftn-356 crayftn: ERROR READLSTA, File = /work/n02/n02/gmann/um/xhwrc/ummodel/ppsrc/UM/control/top_level/readlsta.f90, Line = 5410, Column = 19

Assignment of a CHARACTER expression to a REAL variable is not allowed.

SW_CONTROL(J)%L_SUBSAMPLE=L_SUBSAMPLE


ftn-356 crayftn: ERROR READLSTA, File = /work/n02/n02/gmann/um/xhwrc/ummodel/ppsrc/UM/control/top_level/readlsta.f90, Line = 5453, Column = 36

Assignment of a INTEGER expression to a LOGICAL variable is not allowed.

SW_CONTROL(J)%L_GEOSTATIONARY=L_GEOSTATIONARY


ftn-356 crayftn: ERROR READLSTA, File = /work/n02/n02/gmann/um/xhwrc/ummodel/ppsrc/UM/control/top_level/readlsta.f90, Line = 5454, Column = 40

Assignment of a INTEGER expression to a LOGICAL variable is not allowed.

SW_CONTROL(J)%SAT_DESC=SAT_DESC


ftn-356 crayftn: ERROR READLSTA, File = /work/n02/n02/gmann/um/xhwrc/ummodel/ppsrc/UM/control/top_level/readlsta.f90, Line = 5455, Column = 33

Assignment of a REAL expression to a CHARACTER variable is not allowed.

L_SUBSAMPLE=LW_CONTROL(J)%L_SUBSAMPLE


ftn-356 crayftn: ERROR READLSTA, File = /work/n02/n02/gmann/um/xhwrc/ummodel/ppsrc/UM/control/top_level/readlsta.f90, Line = 5518, Column = 22

Assignment of a LOGICAL expression to a INTEGER variable is not allowed.

L_GEOSTATIONARY=LW_CONTROL(J)%L_GEOSTATIONARY


ftn-356 crayftn: ERROR READLSTA, File = /work/n02/n02/gmann/um/xhwrc/ummodel/ppsrc/UM/control/top_level/readlsta.f90, Line = 5519, Column = 26

Assignment of a LOGICAL expression to a INTEGER variable is not allowed.

SAT_DESC=LW_CONTROL(J)%SAT_DESC


ftn-356 crayftn: ERROR READLSTA, File = /work/n02/n02/gmann/um/xhwrc/ummodel/ppsrc/UM/control/top_level/readlsta.f90, Line = 5520, Column = 19

Assignment of a CHARACTER expression to a REAL variable is not allowed.

LW_CONTROL(J)%L_SUBSAMPLE=L_SUBSAMPLE


ftn-356 crayftn: ERROR READLSTA, File = /work/n02/n02/gmann/um/xhwrc/ummodel/ppsrc/UM/control/top_level/readlsta.f90, Line = 5571, Column = 36

Assignment of a INTEGER expression to a LOGICAL variable is not allowed.

LW_CONTROL(J)%L_GEOSTATIONARY=L_GEOSTATIONARY


ftn-356 crayftn: ERROR READLSTA, File = /work/n02/n02/gmann/um/xhwrc/ummodel/ppsrc/UM/control/top_level/readlsta.f90, Line = 5572, Column = 40

Assignment of a INTEGER expression to a LOGICAL variable is not allowed.

LW_CONTROL(J)%SAT_DESC=SAT_DESC


ftn-356 crayftn: ERROR READLSTA, File = /work/n02/n02/gmann/um/xhwrc/ummodel/ppsrc/UM/control/top_level/readlsta.f90, Line = 5573, Column = 33

Assignment of a REAL expression to a CHARACTER variable is not allowed.

Cray Fortran : Version 8.0.0.135 (u80076f80134i80112p80226a80002e80002z80226)
Cray Fortran : (x8008r80006w80001t8005b80035)
Cray Fortran : Wed Nov 14, 2012 15:02:59
Cray Fortran : Compile time: 0.2680 seconds
Cray Fortran : 5664 source lines
Cray Fortran : 19 errors, 0 warnings, 0 other messages, 0 ansi
Cray Fortran : "explain ftn-message number" gives more information about each message.

comment:3 Changed 7 years ago by grenville

Graham

There are some things that need to be done to change a MONSooN job into a HECToR job (please see http://cms.ncas.ac.uk/index.php/um-faq/1542-convert-monsoon-job-to-hector) - I see that you don't have fcm:um_br/pkg/Config/VN7.3_ncas/src in your list of branches and that Section 96 should be set to 1A and is currently 1C (although I doubt this is the cause of the compilation errors).

Grenville

comment:4 Changed 7 years ago by gmann

Hi Grenville,

Thanks a lot — I did refer to UM FAQ 5 on porting from MONSOON to HECToR and I did already change that Section 96 from 1C to 1A (although it wasn't done when I first tried it).

Re: the VN7.3_ncas branch — I didn't put that in because I thought that it was already included in the branch that Mohit had put together —- previously we had several separate branches when we ran on MONSOON — but with the merging process, Mohit packaged them all together into a single branch.

However — maybe I was wrong about that — I'll try adding in the 7.3_NCAS pkg branch as you suggest.

Thanks again for your prompt responses to my questions.

Cheers
Graham

comment:5 Changed 7 years ago by ros

Hi Graham,

The problem with L_subsample is fixed in my branch

fcm:um_br/dev/ros/VN7.3_HadGEM3-A_r2.0_fixes

Cheers,
Ros.

comment:6 Changed 7 years ago by gmann

Hi Ros,

Thanks a lot for your help.

I thought that had been merged into the UKCA branch that I'm using but it looks like that's not the case — I'll add that branch in additionally then.

I'm using the same branches on MONSOON and it *seems* not to be causing a problem there…

Do you know whether that bug would cause a problem during run-time?

Cheers
Graham

comment:7 Changed 7 years ago by gmann

Hi Ros, Grenville,

Thanks for your help with this — I checked Ros's branch VN7.3_HadGEM3-A_r2.0_fixes and saw that there was really only one fix in there which was to move the include statement for satopt.h
(and associated if(defined) statements) to earlier in readlsta.

So I just made that change in my branch "VN7.3_HG3r2_mergCJ_nprim_Radv2_HECToR" which
just merged in Mohit's "VN7.3_HG3r2_mergCJ_nprim_Radv2" branch and applied that bug-fix.

When I repeated the run pointing to that branch it then compiles OK.

There's a run-time error now but I know what that is — it's because I've not yet set
up some small executables that are needed in the "RADAER" module for the UKCA aerosol
optical properties for the direct radiative effects. Need to copy them over to HECToR
from MONSOON and make a top/bottom scripts like those on MONSOON and add them to the
job in the UMUI. Mohit has sent me instructions for how to do this.

I'll sort that out today and it should hopefully run OK then.

Thanks again for your help — I think this is sorted now. :-)

Cheers
Graham

comment:8 Changed 7 years ago by ros

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.