Opened 12 years ago

Closed 11 years ago

#97 closed help (fixed)

UM version 6.1 idealised runs

Reported by: lois Owned by: lois
Component: UM Model Keywords:
Cc: Platform:
UM Version: 6.1

Description

We have had a report of problems with UM vn6.1 idealised runs failing.
" Carol has taken my run xbmha as a starting point. This is a 5.5 idealized job that was working OK on newton. As you know, we've been having troubles trying to get this to work satisfactorily on HPCx, for both 5.5 and 6.1. She was able to get this job working at 6.1 on the MO machine.

A straight copy of Carol's job can be seen at xcptb. Both Richard and myself have been trying to run the same job (or as close to it as we can manage) at HPCx, but without success. My attempt can be seen at xcpta (it contains what I understand to be machine-specific changes, plus Richard Forbes mods for the idealized 6.1 UM. Richard F told me that these shouldn't matter and I've tried with and without these.) Richard K's attempt can be seen at xcmlp. Reconfiguration seems ok but we are both getting segmentation faults very early in the run.

Our previous attempts at getting it to work at 6.1 seemed to get slightly further through the run for whatever reason. My efforts are xbzsw and xbzsv. Richard K's are xcmla and xcmld. "

We have so far failed to get to the bottom of this problem.

We now have a further report of reconfiguration failing for an idealised run.
So job xcrgd, a idealised run without tracers reconfigures and runs but

job xcsfb, the same idealised job but with tracers, gives a segmentation fault when reconfiguring. Victoria Sinclair, who reported this problem, said that on investigation it looked as though the reconfiguration had almost completed but it seemed to fail when calculating the exner pressure.

Lois

Change History (2)

comment:1 Changed 12 years ago by lois

  • Owner changed from um_support to lois
  • Status changed from new to assigned

I think that we are getting close to a solution to this problems which may have been caused by using climate mods for what is essentially an NWP job.
This ticket will be kept open while we carry out the final tests of a sample job.

Lois

comment:2 Changed 11 years ago by lois

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.