Opened 7 years ago

Closed 5 years ago

#981 closed help (completed)

Sea ice ancillary file causing model crash

Reported by: ab728 Owned by: jeff
Component: UM Model Keywords:
Cc: Platform: <select platform>
UM Version: 7.3

Description

I have running with some newly created SST and sea ice ancillary files but the model is crashing in the 2nd timestep with the message:
"GCR( 2 ) failed to converge in 100 iterations."

The problem seems to be with the sea ice. The crash only occurs when xancil converts to sea-ice fractions from percentages. It runs fine if I choose a SST value to create a sea-ice mask. It even works if I convert to fractions but also select a cut-off value to convert to a mask. I think it is ok for me to use either of these other methods but am curious as to why it does not work otherwise.

Many thanks,
Tara

Change History (6)

comment:1 Changed 7 years ago by jeff

  • Owner changed from um_support to jeff
  • Status changed from new to accepted

Hi Tara

When you create your sst ancillary have you tried selecting "Enter SST value over Sea-Ice" and using the value 271.35? Also did you use 271.4 for the minimum SST value? If the SST and sea-ice values don't match up then quite often the model can go unstable.

Jeff.

comment:2 Changed 7 years ago by ab728

Hi Jeff,

I have just tried that. No luck I'm afraid. It now crashes in the 3rd timestep. My xancil job is here if it helps:
/work/n02/n02/ab728/ancils/mkancils/sst_test.job

Thanks,
Tara

comment:3 Changed 7 years ago by jeff

Hi Tara

If using one of the over sea ice methods is ok then it would probably be easier to do that, as it might not be possible to find out why your job goes unstable, it could just be due to your sea ice values.

Jeff.

comment:4 Changed 7 years ago by ab728

Hi Jeff,

How valid do you think that is though? I'm currently using the option 'Calculate sea-ice fraction values from SST value' and setting this to 273.40. By eye, I can see this generally puts on an ice mask where there is sea-ice so looks ok. But does the code require fractional values for any reason? e.g. if there's very little sea-ice, treat it as sea…?

Best,
Tara

comment:5 Changed 7 years ago by ab728

Hi Jeff,

Unfortunately, the set-up I described in my previous message has caused my job to crash with the same error after about 6 months. Please let me know if there is anything you can think of that is causing this crash. (I didn't check the two options you mentioned when I had created that file…).

Thanks,

Tara

comment:6 Changed 5 years ago by jeff

  • Resolution set to completed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.