Opened 7 years ago

Closed 7 years ago

#987 closed help (fixed)

Byte Swap - taking dumps from MONSooN to HECToR

Reported by: SimonDriscoll Owned by: willie
Component: UM Model Keywords:
Cc: Platform: <select platform>
UM Version: <select version>

Description

Hi,

I've been told that to use MONSooN dumps on HECToR to run the same model I may have to byte swap runs.

I've done a quick google search, e.g.:

"he problem is caused by the files on Hector being little endian and the ukmo idl library wanting big endian files. There are utilities available to byte swap the data, on Hector you can use

bigend -32 xdjkfa_pj066.pp xdjkfa_pj066_be.pp

You should run either of these commands after running ff2pp on Hector, then the files should work okay. "

but not came up with whether this specifically needs to be done for MONSooN to HECToR and how to do it (if there are any subtleties/differences).

Thanks,

Simon

Change History (13)

comment:1 Changed 7 years ago by SimonDriscoll

*"I may have to byte swap runs."

byte swap dumps. Apologies.

comment:2 Changed 7 years ago by willie

  • Owner changed from um_support to willie
  • Status changed from new to accepted

Hi Simon,

I regularly transfer start dumps from MONSooN to HECToR and don't byte swap them. There hasn't been a problem.

Regards,

Willie

comment:3 Changed 7 years ago by SimonDriscoll

Hi Willie,

thanks for this. So to confirm: it's ok to set off a run with MONSooN start dumps on HECToR and it will run?

Thanks again.

Simon

comment:4 Changed 7 years ago by SimonDriscoll

*just found someone else who said they've did it and that there weren't any complaints.

Simon

comment:5 Changed 7 years ago by SimonDriscoll

Hi,

just to tag a quick request onto this. I've just noticed that when I do emacs on HECToR I get:

sdrisc@hector-xe6-7:~/um/umui_out> emacs xgxwd000.xgxwd.d12340.t161322.comp.leave &
[1] 16525
sdrisc@hector-xe6-7:~/um/umui_out> X11 connection rejected because of wrong authentication.
X11 connection rejected because of wrong authentication.
Display hector-xe6-7:10.0 unavailable, simulating -nw

I also have when I log in:

/usr/bin/xauth: error in locking authority file /home/n02/n02/sdrisc/.Xauthority

I've checked some internet advice, so of which suggests deleting the file - which seems a bit risky. Do you know what to do in this case?

Thanks,

Simon

comment:6 Changed 7 years ago by willie

Hi Simon,

The .Xauthority file is clearly damaged, since xauth can't read it, so deleting it won't worsen things.

Regards,

Willie

comment:7 Changed 7 years ago by SimonDriscoll

Ok. I have no idea what it does, but I assume I need such a file (else why would it be 'put' on HECToR?). Do you know if I should do anything after deleting it (as far as HECToR matters are concerned)?

Thanks

comment:8 Changed 7 years ago by willie

Hi Simon,

I would rename it .Xauthority.old, logout and login again and try emacs. I am not sure of the details either.

regards,

Willie

comment:9 Changed 7 years ago by SimonDriscoll

Hi Willie,

apologies for this, I'm currently at a workshop, and I've tried some of the solutions online, but seem to run into the same errors as they have. Do you know what to do in this case? I have only small pockets of time, and currently can't run anything on the UM as a result of this locking.

I'll keep on looking at the same time.

Thanks,

Simon

comment:10 Changed 7 years ago by SimonDriscoll

Notably, on submitting UM jobs that have ran before I now get:

Calling FCM_MAIN_SCR - local…
(This may take several minutes.)

FCM_MAIN: Calling Extract …
Base extract: failed
See extract output file /home/SimonDriscoll/um/um_extracts/xhywa/umbase/ext.out
FCM_MAIN: Extract failed
Tidying up directories …
/usr/bin/xauth: error in locking authority file /home/n02/n02/sdrisc/.Xauthority
FCM_MAIN stopped with return code 12

/usr/bin/xauth: error in locking authority file /home/n02/n02/sdrisc/.Xauthority

Simon

comment:11 Changed 7 years ago by SimonDriscoll

Managed to get this to work now by:

xauth -b quit

then deleting some space in um/um_extracts which gave me:

FCM_MAIN stopped with return code 2

Then I found a ticket with similar problems. Deleting the actual job as advised and got:

FCM_MAIN stopped with return code 25

I've checked the issues with this too, and it seems lots of people have had issues with the fcm file. I checked mine and

emacs .fcm &

gave me

inc ~um/fcm/etc/um_revisions.cfg
inc ~um/fcm/etc/um_tutorial_revisions.cfg

I then exited from HECToR (it seemed to be creating a new .Xauthority file each time and submitted (the same job) again and got:

FCM_MAIN: Calling Extract …
Base extract: failed
See extract output file /home/SimonDriscoll/um/um_extracts/xhywa/umbase/ext.out
FCM_MAIN: Extract failed
Tidying up directories …
FCM_MAIN stopped with return code 12

And I can't find anything on google to help me with a return code 12 problem. Could you advise?

Thanks,

Simon

comment:12 Changed 7 years ago by SimonDriscoll

Solved!

Simon

comment:13 Changed 7 years ago by willie

  • Resolution set to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.