Opened 8 years ago

Closed 8 years ago

#989 closed help (fixed)

Can't seem to create a new v7.3 UM branch within FCM

Reported by: gmann Owned by: ros
Component: FCM Keywords:
Cc: Platform: PUMA
UM Version: 7.3

Description (last modified by ros)

I created a new ticket within UM Trac (number 454) to refer
to a new v7.3 branch that I want to make to hold code changes
to the GLOMAP-mode routines within UKCA to allow some
sea-spray geoengineering simulations to be carried out in
HadGEM-UKCA.

It is strange because although I created the new ticket OK, when I try to create a new v7.3 branch on PUMA that points to the ticket, it seems to just create a new v8.2 branch rather than a new v7.3 branch as I am specifying.

The command I've run was:

fcm branch -c -n HG3r2_mergCJ_nprim_Radv2_HECToR_ssgeo —revision vn7.3 -k 454 fcm:um

By my reckoning, that ought to create a new v7.3 branch with the name "vn7.3_HG3r2_mergCJ_nprim_Radv2_HECToR_ssgeo"

But instead it is created a branch at v8.2 — i.e. with the name
"vn8.2_HG3r2_mergCJ_nprim_Radv2_HECToR_ssgeo"

I've checked the syntax on the help page and it looks like I have this correct as it's stated below as:

fcm branch -c -n <branch_name> —revision <revision> [-k <ticket number>] fcm:um

What am I doing wrong?

Thanks a lot for your help,

Cheers
Graham

Change History (3)

comment:1 Changed 8 years ago by ros

  • Description modified (diff)
  • Status changed from new to accepted

Hi Graham,

Try

fcm branch-create -k 454 HG3r2_mergCJ_nprim_Radv2_HECToR_ssgeo fcm:um_tr@vn7.3

I'll update the Tutorial and FAQ accordingly.

Regards,
Ros.

comment:2 Changed 8 years ago by gmann

Hi Ros,

Thanks for your very fast reply!

I tried that and it works now.

Thanks again for your help,

Cheers
Graham

comment:3 Changed 8 years ago by ros

  • Resolution set to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.